当前位置: 首页 > 工具软件 > Domination > 使用案例 >

Domination(概率DP)

申屠亦
2023-12-01
Domination
点我找原题

Time Limit: 8 Seconds       Memory Limit: 131072 KB       Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard with Nrows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= NM <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

dp[i][j][k]表示已经覆盖了i行j列且使用了k颗棋子时的概率。。。。

 

注意转移,放一颗棋子后可能行和列的覆盖数不会增加,也有可能只增加了行,也有可能只增加了列,还有可能同时增加了行列的覆盖数。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[55][55][3600];
void DP(int n,int m)
{
int i,j,k;
dp[0][0][0]=1;
for(int i = 1; i <= n; ++i){
for(int j = 1; j <= m; ++j){
for(int k = max(i,j);k <= i*j; ++k){
double p1 = dp[i][j][k-1]*(i*j - k + 1);//行列覆盖都不增加
double p2 = dp[i-1][j][k-1]*(n-i+1)*j;//增加行
double p3 = dp[i][j-1][k-1]*i*(m - j + 1);//增加列
double p4 = dp[i-1][j-1][k-1]*(n - i + 1)*(m - j + 1);//既增加行 又增加列
dp[i][j][k] = (p1 + p2 + p3 + p4)/(n*m - k + 1);
}
}
}
double ans = 0;
for(int i = max(n,m); i <= n*m; ++i)
ans += dp[n][m][i]*i - dp[n][m][i-1]*i;
printf("%.9f\n",ans);
}
int main(int argc, char *argv[])
{
int t,n,m,i,j,k;

cin>>t;
while(t--)
{
memset(dp,0,sizeof(dp));
cin>>n>>m;
DP(n,m);
}
return 0;
}



 类似资料: