http://acm.hdu.edu.cn/showproblem.php?pid=1756
Cupid's ArrowTime Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3177 Accepted Submission(s): 1142 Problem Description 传说世上有一支丘比特的箭,凡是被这支箭射到的人,就会深深的爱上射箭的人。
Input 本题目包含多组测试,请处理到文件结束。
Output 对于每枝箭,如果Lele射中了靶子,就在一行里面输出"Yes",否则输出"No"。
Sample Input 4 10 10 20 10 20 5 10 5 2 15 8 25 8
Sample Output Yes No
Author |
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
#define eps 1e-8
struct point
{
double x;
double y;
}po[10000],temp;
double multi(point p0, point p1, point p2)//j计算差乘
{ return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);}
bool across(point s1,point e1,point s2,point e2)//判断线段是否相交(非规范相交)
{
return
multi(s1,e1,s2)*multi(s1,e1,e2) < -eps&&
multi(s2,e2,s1)*multi(s2,e2,e1) < -eps;
}
int main()
{
int n,t;
int i,j,k;
int count;
point temp1;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
scanf("%lf%lf",&po[i].x,&po[i].y);
scanf("%d",&t);
while(t--)
{
count=0;
scanf("%lf%lf",&temp.x,&temp.y);
temp1=temp;
temp1.x+=100008;
temp1.y+=98430;
po[i]=po[0];
for(i=0;i<n;i++)
if(across(temp,temp1,po[i],po[i+1]))
count++;
if(count==0 || count%2==0)
printf("No\n");
else
printf("Yes\n");
}
}
return 0;
}