当前位置: 首页 > 工具软件 > junior-theme > 使用案例 >

POJ1743:Musical Theme(后缀数组)

牟子真
2023-12-01

Musical Theme
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 30856 Accepted: 10310

Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings. 
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 
  • is at least five notes long 
  • appears (potentially transposed -- see below) again somewhere else in the piece of music 
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
Given a melody, compute the length (number of notes) of the longest theme. 
One second time limit for this problem's solutions! 

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
The last test case is followed by one zero. 

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output

5

Hint

Use scanf instead of cin to reduce the read time.

意:有N(1 <= N <=20000)个音符的序列来表示一首乐曲,每个音符都是1..88范围内的整数,现在要找一个重复的主题。“主题”是整个音符序列的一个子串,它需要满足如下条件:

    1.长度至少为5个音符。

    2.在乐曲中重复出现。(可能经过转调,“转调”的意思是主题序列中每个音符都被加上或减去了同一个整数值)

    3.重复出现的同一主题不能有公共部分。

思路:后缀数组,作差后就可以套模板了,二分答案时SA[i]距离应严格>mid,否则就出现数字重复使用的错误了。

# include <iostream>
# include <cstdio>
# include <cstring>
# include <algorithm>
#define LL long long
#define N 20005
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define EXP 1e-8
using namespace std;
int wa[N],wb[N],wsf[N],wv[N],sa[N];
int Rank[N],height[N],s[N],a[N],n;
char str1[N],str2[N];
int cmp(int *r,int a,int b,int k)
{
    return r[a]==r[b]&&r[a+k]==r[b+k];
}
void getsa(int *r,int *sa,int n,int m)
{
    int i,j,p,*x=wa,*y=wb,*t;
    for(i=0; i<m; i++)  wsf[i]=0;
    for(i=0; i<n; i++)  wsf[x[i]=r[i]]++;
    for(i=1; i<m; i++)  wsf[i]+=wsf[i-1];
    for(i=n-1; i>=0; i--)  sa[--wsf[x[i]]]=i;
    p=1;
    j=1;
    for(; p<n; j*=2,m=p)
    {
        for(p=0,i=n-j; i<n; i++)  y[p++]=i;
        for(i=0; i<n; i++)  if(sa[i]>=j)  y[p++]=sa[i]-j;
        for(i=0; i<n; i++)  wv[i]=x[y[i]];
        for(i=0; i<m; i++)  wsf[i]=0;
        for(i=0; i<n; i++)  wsf[wv[i]]++;
        for(i=1; i<m; i++)  wsf[i]+=wsf[i-1];
        for(i=n-1; i>=0; i--)  sa[--wsf[wv[i]]]=y[i];
        t=x;
        x=y;
        y=t;
        x[sa[0]]=0;
        for(p=1,i=1; i<n; i++)
            x[sa[i]]=cmp(y,sa[i-1],sa[i],j)? p-1:p++;
    }
}
void getheight(int *r,int n)
{
    int i,j,k=0;
    for(i=1; i<=n; i++)  Rank[sa[i]]=i;
    for(i=0; i<n; i++)
    {
        if(k)
            k--;
        else
            k=0;
        j=sa[Rank[i]-1];
        while(r[i+k]==r[j+k])
            k++;
        height[Rank[i]]=k;
    }
}
bool check(int x)
{
    int imax, imin;
    imax = imin = sa[1];
    for(int i=2; i<=n; ++i)
    {
        if(height[i]>=x)
        {
            imax = max(imax, sa[i]);
            imin = min(imin, sa[i]);
            continue;
        }
        if(imax-imin>x) return true;
        else imax = imin = sa[i];
    }
    return imax-imin>x;
}

int main()
{
    while(~scanf("%d",&n),n)
    {
        for(int i=0; i<n; ++i) scanf("%d",&s[i]);
        for(int i=0; i<n-1; ++i) s[i] = s[i+1]-s[i]+88;
        s[--n] = 0;
        getsa(s,sa,n+1,200);
        getheight(s,n);
        int L=0, R=(n+1)/2;
        while(L<=R)
        {
            int mid = L+R>>1;
            if(check(mid)) L = mid+1;
            else R = mid-1;
        }
        ++R;
        printf("%d\n",R<5?0:R);
    }
}


 类似资料: