UVA-12096(stl---set与stack与map大杂烩)

莫河
2023-12-01

The SetStack Computer UVA - 12096
Background from Wikipedia: “Set theory is a
branch of mathematics created principally by the
German mathematician Georg Cantor at the end of
the 19th century. Initially controversial, set theory
has come to play the role of a foundational theory
in modern mathematics, in the sense of a theory
invoked to justify assumptions made in mathematics concerning the existence of mathematical objects
(such as numbers or functions) and their properties.
Formal versions of set theory also have a foundational role to play as specifying a theoretical ideal
of mathematical rigor in proofs.”
Given this importance of sets, being the basis of mathematics, a set of eccentric theorist set off to
construct a supercomputer operating on sets instead of numbers. The initial SetStack Alpha is under
construction, and they need you to simulate it in order to verify the operation of the prototype.
The computer operates on a single stack of sets, which is initially empty. After each operation, the
cardinality of the topmost set on the stack is output. The cardinality of a set S is denoted |S| and is the
number of elements in S. The instruction set of the SetStack Alpha is PUSH, DUP, UNION, INTERSECT,
and ADD.

• PUSH will push the empty set {} on the stack.

• DUP will duplicate
the topmost set (pop the stack, and then push that set on the stack
twice).

• UNION will pop the stack twice and then push the union of
the two sets on the stack.

• INTERSECT will pop the stack twice and
then push the intersection of the two sets on the stack.

• ADD will pop the stack twice, add the first set to the second one, and then
push the resulting set

on the stack.
For illustration purposes, assume that the topmost element of the stack is

A = {{}, {{}}} and that the next one is
B = {{}, {{{}}}} For these sets, we have |A| = 2 and |B| = 2. Then:
• UNION would result in the set {{}, {{}}, {{{}}}}. The output is 3.
• INTERSECT would result in the set {{}}. The output is 1.
• ADD would result in the set {{}, {{{}}}, {{},{{}}}}. The output is 3.

Input
An integer 0 ≤ T ≤ 5 on the first line gives the cardinality of the set of test cases. The first line of each
test case contains the number of operations 0 ≤ N ≤ 2000. Then follow N lines each containing one of
the five commands. It is guaranteed that the SetStack computer can execute all the commands in the
sequence without ever popping an empty stack.
Output
For each operation specified in the input, there will be one line of output consisting of a single integer.
This integer is the cardinality of the topmost element of the stack after the corresponding command
has executed. After each test case there will be a line with ‘***’ (three asterisks).
Sample Input

2
9
PUSH
DUP
ADD
PUSH
ADD
DUP
ADD
DUP
UNION
5
PUSH
PUSH
ADD
PUSH
INTERSECT

Sample Output

0
0
1
0
1
1
2
2
2
***
0
0
1
0
0
***

注意:
1.求两个集合交集:(c=a∩b)
set_intersection(a.begin(),a.end(),b.begin(),b.end(),inserter(c,c.begin()))
2.求两个集合并集:(c=aUb)
set_union(a.begin(),a.end(),b.begin(),b.end(),inserter(c,c.begin()))
3.每一个集合用一个id去标记:
map<set,int> setId;
4.每存一个标记就入:
vector<set > setList;

ac code:

#include<bits/stdc++.h>
using namespace std;

vector<set<int> > setList;
map<set<int>,int> setId;

int getSetId(const set<int>& _set){
	if(setId.find(_set)!=setId.end())return setId[_set];
	else{
		setList.push_back(_set);
		return setId[_set]=setList.size()-1;
	}
}

int main(){
	
	int t;
	cin>>t;
	while(t--){
		int num;
		cin>>num;
		setId.clear(),setList.clear();
		stack<int> sta;
		
		string ss;
		while(num--){
			cin>>ss;
			if(ss=="PUSH"){
				sta.push(getSetId(set<int>()));
			}else if(ss=="DUP"){
				sta.push(sta.top());
			}else{
				set<int> a,b,c;
				a=setList[sta.top()],sta.pop();
				b=setList[sta.top()],sta.pop();
				
				if(ss=="UNION")set_union(a.begin(),a.end(),b.begin(),b.end(),inserter(c,c.begin()));	
				else if(ss=="INTERSECT")set_intersection(a.begin(),a.end(),b.begin(),b.end(),inserter(c,c.begin()));
				else if(ss=="ADD")c=b,c.insert(setId[a]);
				sta.push(getSetId(c));
			}
			printf("%d\n",setList[sta.top()].size());
		}
		printf("***\n");
	}
	return 0;
} 
 类似资料: