A Lazy Worker
Time Limit: 1000MS | | Memory Limit: 10000K |
Total Submissions: 1131 | | Accepted: 384 |
Description
There is a worker who may lack the motivation to perform at his peak level of efficiency because he is lazy. He wants to minimize the amount of work he does (he is Lazy, but he is subject to a constraint that he must be busy when there is work that he can do.)
We consider a set of jobs 1, 2,..., n having processing times t1, t2,...,tn respectively. Job i arrives at time ai and has its deadline at time di. We assume that ti, ai, and di have nonnegative integral values. The jobs have hard deadlines, meaning that each job i can only be executed during its allowed interval Ii=[ai, di]. The jobs are executed by the worker, and the worker executes only one job at a time. Once a job is begun, it must be completed without interruptions. When a job is completed, another job must begin immediately, if one exists to be executed. Otherwise, the worker is idle and begins executing a job as soon as one arrives. You should note that for each job i, the length of Ii, di - ai, is greater than or equal to ti, but less than 2*ti.
Write a program that finds the minimized total amount of time executed by the worker.
Input
The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. The number of jobs (0<=n<=100) is given in the first line of each test case, and the following n lines have each job's processing time(1<=ti<=20),arrival time(0<=ai<=250), and deadline time (1<=di<=250) as three integers.
Output
Print exactly one line for each test case. The output should contain the total amount of time spent working by the worker.
Sample Input
3
3
15 0 25
50 0 90
45 15 70
3
15 5 20
15 25 40
15 45 60
5
3 3 6
3 6 10
3 14 19
6 7 16
4 4 11
Sample Output
50
45
15
题意:有一个天平,若干砝码,要用上所有砝码,使天平处于平衡状态,问有几种不同情况。
当放上去的砝码不同时,天平会有不同的平衡状态,设为j,当j<0时表示左边重;当j>0时表示右边重;当j=0时则天平处于平衡。
为了使数组下标不出现负数情况,要用到状态转移(见代码),所以,当j=7500时为平衡状态。
/*完全背包*/
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int c,g,hook[25],weight[25];
int dp[25][15050];
//dp[i][j]表示放上第i个后的平衡系数为j的possobilities。
//为了使数组下标不出现负数情况,状态转移。[-20*15*25 ~ 20*15*25]->[0 ~ 2*20*15*25]即[0 ~ 15000]
//dp[i][7500]是平衡状态
int main()
{
//freopen("in.txt","r",stdin);
memset(dp,0,sizeof(dp));
scanf("%d%d",&c,&g);
for(int i = 0; i < c; i++)
scanf("%d",&hook[i]);
for(int i= 0; i < g; i++)
scanf("%d",&weight[i]);
dp[0][7500]=1;
for(int i = 0; i < g; i++)
{
for(int j = 0; j <= 15000; j++)
{
if(dp[i][j])
for(int k = 0; k < c; k++)
dp[i + 1][j + weight[i] * hook[k]] += dp[i][j];
}
}
printf("%d\n",dp[g][7500]);
}