The people of Mohammadpur have decided to paint each of their houses red, green, or blue. They've also decided that no two neighboring houses will be painted the same color. The neighbors of house i are houses i-1 and i+1. The first and last houses are not neighbors.
You will be given the information of houses. Each house will contain three integers "R G B" (quotes for clarity only), where R, G and B are the costs of painting the corresponding house red, green, and blue, respectively. Return the minimal total cost required to perform the work.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case begins with a blank line and an integer n (1 ≤ n ≤ 20) denoting the number of houses. Each of the next n lines will contain 3 integers "R G B". These integers will lie in the range [1, 1000].
Output
For each case of input you have to print the case number and the minimal cost.
Sample Input
2
4
13 23 12
77 36 64
44 89 76
31 78 45
3
26 40 83
49 60 57
13 89 99
Sample Output
Case 1: 137
Case 2: 96
// 代码很简洁,
// 就是需要剪枝
// 还有就是有个规律: 就是 DFS深度 不超过20
// 一般都可以改
#include<bits/stdc++.h>
using namespace std;
int num[21][4];
int ans;
int n;
void dfs( int row ,int res ,int color ){
if( res > ans )
return ;
if( row == n+1 ){
if( res < ans )
ans=res;
return ;
}
for( int i=0;i<=2;i++){
if( color==i ){
if( i==0 ){
dfs( row+1, res+num[row][i+1] ,i+1);
dfs( row+1, res+num[row][i+2] ,i+2);
}
else if(i==1){
dfs( row+1, res+num[row][i-1] ,i-1);
dfs( row+1, res+num[row][i+1] ,i+1);
}
else if( i==2){
dfs( row+1, res+num[row][i-1] ,i-1);
dfs( row+1, res+num[row][i-2] ,i-2);
}
}
else continue;
}
}
int main(void){
int cae;
int cnt=0;
scanf("%d",&cae);
while( cae-- ){
getchar( );
scanf("%d",&n);
memset(num,0,sizeof(num));
for( int i=1;i<=n;i++)
for( int j=0;j<=2;j++)
scanf("%d",&num[i][j]);
ans=1000000;
dfs(1,0,0);
dfs(1,0,1);
dfs(1,0,2);
printf("Case %d: %d\n",++cnt,ans);
}
return 0;
}