当前位置: 首页 > 工具软件 > Locomotive > 使用案例 >

F - A Mini Locomotive

纪辰沛
2023-12-01

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows:

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives.
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches.
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1.

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60.

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers.

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives.

Input

The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches.

Output

There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.

Sample Input

1

7

35 40 50 10 30 45 60

2

Sample Output

240

  • 题意概括  :

给你三个车头,然后是n节车厢,以及每节车厢的乘客数,然后给你一个k表示每个车头所能拉的车厢数车头所拉车厢必须是连续的,问所能拉的最大乘客数。

  • 解题思路  :

k节车厢变成一个整体,每k节车厢的乘客数相加,然后判断取那几个连续的k节车厢使得所拉乘客数最多。I表示车头,j表示车厢数,a【j】表示k节车厢的乘客数,状态转移方程 :dp[i][j] = max(dp[i][j-1],dp[i-1][j-m]+a[j]);

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

int car[50010],dp[4][60000],a[50010];
int n,m;

int DP()
{
	int i,j,k;
	
	for(i = 1;i<=3;i ++)
	{
		for(j = m;j<=n;j ++)
		{
			dp[i][j] = max(dp[i][j-1],dp[i-1][j-m]+a[j]);
		}
	}
	return dp[3][n];
}
int main()
{
	int T,i,j,sum;
	
	scanf("%d",&T);
	while(T --)
	{
		memset(dp,0,sizeof(dp));
		scanf("%d",&n);
		for(i = 1;i<=n;i ++)
		{
			scanf("%d",&car[i]);
		}
		car[0] = 0;
		scanf("%d",&m);
		a[0] = car[0];
		for(i = 1;i<=m;i ++)
		{
			a[i] = a[i-1]+car[i];
		}
		sum = a[m];
		for(i = m+1;i<=n;i ++)
		{
			sum += car[i];
			sum -= car[i-m];
			a[i] = sum;
		}
		printf("%d\n",DP());
	}
	return 0;
}

 

 类似资料: