Problem describe:
A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows:
For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60.
If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers.
Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives.
Input
The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches.
Output
There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.
Sample Input
1
7
35 40 50 10 30 45 60
2
Sample Output``
240
这题虽可以看成是01背包,但是却不能用一维的了,这里的dp[i][j]表示前i节车厢用j个车头来拉时的最大乘客量。
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
int main()
{
int n,t,w[60000],v[60000],dp[80000][4],m,i,j;
cin>>t;
while(t--)
{
memset(dp,0,sizeof(dp));
cin>>n;
for(i=1;i<=n;i++)
{
cin>>w[i];
v[i]=v[i-1]+w[i];//v[i]存储的是前i节车厢所能承载的总容量。
}
cin>>m;
for(i=m;i<=n;i++)
for(j=3;j>=1;j--)
dp[i][j]=max(dp[i-1][j],dp[i-m][j-1]+v[i]-v[i-m]);
cout<<dp[n][3]<<endl;
}
return 0;
}