当前位置: 首页 > 工具软件 > mp-Math > 使用案例 >

HDU-5615-Jam's math problem

贺亦
2023-12-01
D - Jam's math problem
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Jam has a math problem. He just learned factorization. 
He is trying to factorize $ax^2+bx+c$ into the form of $pqx^2+(qk+mp)x+km=(px+k)(qx+m)$. 
He could only solve the problem in which p,q,m,k are positive numbers. 
Please help him determine whether the expression could be factorized with p,q,m,k being postive.
 

Input

The first line is a number $T$, means there are $T(1 \leq T \leq 100 )$ cases 

Each case has one line,the line has $3$ numbers $a,b,c (1 \leq a,b,c \leq 100000000)$
 

Output

You should output the "YES" or "NO".
 

Sample Input

2 1 6 5 1 6 4
 

Sample Output

YES NO

Hint

The first case turn $x^2+6*x+5$ into $(x+1)(x+5)$ 
         
 

题意:给你a,b,c。让你求能否写成(pqx^2+(qk+mp)x+km=(px+k)(qx+m))这种形式。都是整数。

思路:挺难想到的,要建立方程。在一般式的情况下,x=(-b+-sqrt(b*b-4*a*c))/(2*a);

pqx^2+(qk+mp)x+km=(px+k)(qx+m)这种情况下。x1=(-1)*(k/p),x2=(-1)*(m/q);所以可知,只要sqrt(b*b-4*a*c)结果是整数,就满足条件。

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		__int64 a,b,c;
		scanf("%I64d%I64d%I64d",&a,&b,&c);
		__int64 temp;
		temp=sqrt(b*b-4*a*c);
		if(temp*temp==(b*b-4*a*c)){
			printf("YES\n");
		}
		else
			printf("NO\n");
	}
	return 0;
} 


 类似资料:

相关阅读

相关文章

相关问答