当前位置: 首页 > 工具软件 > brigade > 使用案例 >

Bucket Brigade(bfs)

羊舌富
2023-12-01

题目描述
A fire has broken out on the farm, and the cows are rushing to try and put it out!
The farm is described by a 10×10 grid of characters like this:




…B…

…R…


…L…

The character ‘B’ represents the barn, which has just caught on fire. The ‘L’ character represents a lake, and ‘R’ represents the location of a large rock.

The cows want to form a “bucket brigade” by placing themselves along a path between the lake and the barn so that they can pass buckets of water along the path to help extinguish the fire. A bucket can move between cows if they are immediately adjacent in the north, south, east, or west directions. The same is true for a cow next to the lake — the cow can only extract a bucket of water from the lake if she is immediately adjacent to the lake. Similarly, a cow can only throw a bucket of water on the barn if she is immediately adjacent to the barn.

Please help determine the minimum number of ‘.’ squares that should be occupied by cows to form a successful bucket brigade.

A cow cannot be placed on the square containing the large rock, and the barn and lake are guaranteed not to be immediately adjacent to each-other.

输入
The input file contains 10 rows each with 10 characters, describing the layout of the farm.

输出
Output a single integer giving the minimum number of cows needed to form a viable bucket brigade.

样例输入



…B…

…R…


…L…

样例输出
7

思路
bfs裸题

代码实现

#pragma GCC optimize(3,"Ofast","inline")
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int N=105;
const int M=10005;
const int INF=0x3f3f3f;
const ull sed=31;
const ll mod=1e9+7;
const double eps=1e-8;
const double PI=acos(-1.0);
typedef pair<int,int>P;
 
char mp[N][N];
P s,e;
int ar[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int dis[N][N];
bool vis[N][N];
 
int bfs()
{
    queue<P>que;
    que.push(s);
    dis[s.first][s.second]=0;
    while(!que.empty())
    {
        P top=que.front();
        que.pop();
        if(vis[top.first][top.second]) continue;
        if(top==e) break;
        vis[top.first][top.second]=true;
        for(int i=0;i<4;i++)
        {
            int ax=top.first+ar[i][0],ay=top.second+ar[i][1];
            if(!vis[ax][ay] && ax>0 && ay>0 && ax<=10 && ay<=10 && mp[ax][ay]!='R')
            {
                dis[ax][ay]=dis[top.first][top.second]+1;
                que.push(P(ax,ay));
            }
        }
    }
    return dis[e.first][e.second];
}
int main()
{
    for(int i=1;i<=10;i++)
    {
        scanf("%s",mp[i]+1);
        for(int j=1;j<=10;j++)
        {
            if(mp[i][j]=='B') s=P(i,j);
            else if(mp[i][j]=='L') e=P(i,j);
        }
    }
    printf("%d\n",bfs()-1);
    return 0;
}
 类似资料: