Web Navigation (POJ-1028)(堆栈)

祁坚壁
2023-12-01

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you are asked to implement this.
The following commands need to be supported:
BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.
FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.
VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.
QUIT: Quit the browser.
Assume that the browser initially loads the web page at the URL http://www.acm.org/

Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time. The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input

VISIT http://acm.ashland.edu/
VISIT http://acm.baylor.edu/acmicpc/
BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/
BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT

Sample Output

http://acm.ashland.edu/
http://acm.baylor.edu/acmicpc/
http://acm.ashland.edu/
http://www.acm.org/
Ignored
http://acm.ashland.edu/
http://www.ibm.com/
http://acm.ashland.edu/
http://www.acm.org/
http://acm.ashland.edu/
http://www.ibm.com/
Ignored

题意:模拟浏览器的操作。

思路:这道题的话,就是一个模拟的题。我们开两个栈,一个往前一个往后,浏览新的网页时清空往前的栈即可。

AC代码:
 

#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <queue>
#include <stack>
#include <map>
#include <set>
typedef long long ll;
const int maxx=100010;
const int inf=0x3f3f3f3f;
const double eps=1e-5;
using namespace std;
int main()
{
    stack<string>s,p;
    string cmd,url;
    s.push("http://www.acm.org/");
    while(cin>>cmd)
    {
        if(cmd[0]=='B')
        {
            if(s.size()==1)
                cout<<"Ignored"<<endl;
            else
            {
                p.push(s.top());
                s.pop();
                cout<<s.top()<<endl;
            }
        }
        else if(cmd[0]=='F')
        {
            if(p.empty())
                cout<<"Ignored"<<endl;
            else
            {
                s.push(p.top());
                p.pop();
                cout<<s.top()<<endl;
            }
        }
        else if(cmd[0]=='V')
        {
            cin>>url;
            while(!p.empty())
                p.pop();
            s.push(url);
            cout<<s.top()<<endl;
        }
        else if(cmd[0]=='Q')
            break;
    }
    return 0;
}

 

 类似资料: