当前位置: 首页 > 工具软件 > parity > 使用案例 >

Parity

萧允晨
2023-12-01

We define the parity of an integer n as the sum of the bits in binary representation computed modulo
two. As an example, the number 21 = 101012 has three 1s in its binary representation so it has parity
3(mod2), or 1.
In this problem you have to calculate the parity of an integer 1 ≤ I ≤ 2147483647.
Input
Each line of the input has an integer I and the end of the input is indicated by a line where I = 0 that
should not be processed.
Output
For each integer I in the inputt you should print a line ‘The parity of B is P (mod 2).’, where B
is the binary representation of I.
Sample Input
1
2
10
21
0
Sample Output
The parity of 1 is 1 (mod 2).
The parity of 10 is 1 (mod 2).
The parity of 1010 is 2 (mod 2).
The parity of 10101 is 3 (mod 2).
hint 就一道二进制的简单题目,注意细节

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int n;
    while(scanf("%d",&n)&&n!=0)
    {
        int cn=0;
        int a[10001],i;
        i=0;
        while(n!=0)
        {
            a[i]=n%2;
            if(a[i]==1)
                cn++;
            n=n/2;
            i++;
        }
        printf("The parity of ");
        int j;
        for(j=i-1; j>=0; j--)
            printf("%d",a[j]);
        printf(" is %d (mod 2).\n",cn);
    }
    return 0;
}
 类似资料:

相关阅读

相关文章

相关问答