当前位置: 首页 > 工具软件 > minimal-light > 使用案例 >

light oj-1047-neighors house(dp)

司徒云
2023-12-01

The people of Mohammadpur have decided to paint each of their houses red, green, or blue. They've also decided that no two neighboring houses will be painted the same color. The neighbors of house i are houses i-1 and i+1. The first and last houses are not neighbors.

You will be given the information of houses. Each house will contain three integers "R G B" (quotes for clarity only), where R, G and B are the costs of painting the corresponding house red, green, and blue, respectively. Return the minimal total cost required to perform the work.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case begins with a blank line and an integer n (1 ≤ n ≤ 20) denoting the number of houses. Each of the next n lines will contain 3 integers "R G B". These integers will lie in the range [1, 1000].

Output

For each case of input you have to print the case number and the minimal cost.

Sample Input

2

4

13 23 12

77 36 64

44 89 76

31 78 45

 

3

26 40 83

49 60 57

13 89 99

Sample Output

Case 1: 137

Case 2: 96

#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 25
int dp[maxn][4];
int a[maxn][4];
int main()
{
	int t;
	int count = 0;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		count++;
		scanf("%d",&n);
		for(int i = 1; i <= n; i ++)
			for(int j = 1;j <= 3; j ++)
			scanf("%d",&a[i][j]);
		for(int i = 1; i <= n; i ++)
			for(int j = 3; j < 6; j ++)
				dp[i][j%3+1] = a[i][j%3+1] + min(dp[i-1][(j+1)%3+1],dp[i-1][(j-1)%3+1]);
		int res = min(min(dp[n][1],dp[n][3]),dp[n][2]);
		 printf("Case %d: %d\n", count,res);
	}
}
 类似资料: