题目描述
Tak has N cards. On the i-th (1≤i≤N) card is written an integer xi. He is selecting one or more cards from these N cards, so that the average of the integers written on the selected cards is exactly A. In how many ways can he make his selection?
Constraints
1≤N≤50
1≤A≤50
1≤xi≤50
N,A,xi are integers.
Partial Score
200 points will be awarded for passing the test set satisfying 1≤N≤16.
输入
The input is given from Standard Input in the following format:
N A
x1 x2 … xN
输出
Print the number of ways to select cards such that the average of the written integers is exactly A.
样例输入
4 8
7 9 8 9
样例输出
5
提示
The following are the 5 ways to select cards such that the average is 8:
Select the 3-rd card.
Select the 1-st and 2-nd cards.
Select the 1-st and 4-th cards.
Select the 1-st, 2-nd and 3-rd cards.
Select the 1-st, 3-rd and 4-th cards.
思路
用DP的思路解决问题,找到每种情况下得到的数字,再用各个情况下为平均值的结果计算总数
代码实现
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <string>
using namespace std;
typedef long long ll;
const int N=55;
int n,a,x[N];
ll dp[N][3000];
int main()
{
scanf("%d%d",&n,&a);
for(int i=1;i<=n;i++) scanf("%d",&x[i]);
dp[0][0]=1;
ll sum=0;
for(int i=1;i<=n;i++)
{
sum+=x[i];
for(int j=i;j>=1;j--)
for(int k=sum;k>=x[i];k--)
dp[j][k]+=dp[j-1][k-x[i]];
}
ll ans=0;
for(int i=1;i<=n;i++) ans+=dp[i][i*a];
cout<<ans<<endl;
return 0;
}