HUST 1176 Knots

穆展鹏
2023-12-01

Description

An even number N of strands are stuck through a wall. On one side of the wall, a girl ties N/2 knots between disjoint pairs of strands. On the other side of the wall, the girl's groom-to-be also ties N/2 knots between disjoint pairs of strands. You are to find the probability that the knotted strands form one big loop (in which case the couple will be allowed to marry). For example, suppose that N = 4 and you number the strands 1, 2, 3, 4. Also suppose that the girl has created the following pairs of strands by tying knots: {(1, 4), (2,3)}. Then the groom-to-be has two choices for tying the knots on his side: {(1,2), {3,4)} or {(1,3), (2,4)}.

Input

The input file consists of one or more lines. Each line of the input file contains a positive even integer, less than or equal to 100. This integer represents the number of strands in the wall.

Output

For each line of input, the program will produce exactly one line of output: the probability that the knotted strands form one big loop, given the number of strands on the corresponding line of input. Print the probability to 5 decimal places.

Sample Input

4
20

Sample Output

0.66667
0.28377
 
  
把图画出来,枚举全部的可能,然后多试几组就能知道增长规律了
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<functional>
using namespace std;
typedef unsigned long long ull;
typedef long long LL;
const int maxn = 1e5 + 10;
int T, n, m;
double f[maxn];

void Scan(int &x)
{
	char ch;
	while ((ch = getchar()) > '9' || ch < '0');
	int res = ch - '0';
	while ((ch = getchar()) <= '9'&&ch >= '0') res = res * 10 + ch - '0';
	x = res;
}

bool check(int x)
{
	int u = sqrt(x);
	return u*u == x;
}

void init()
{
	f[2] = 1;
	for (int i = 4; i <= 100; i += 2)
	{
		f[i] = f[i - 2] * (i - 2) / (i - 1);
	}
}

int main()
{
	init();
	while (scanf("%d", &n) != EOF)
	{
		printf("%.5lf\n", f[n]);
	}
	return 0;
}



 类似资料:

相关阅读

相关文章

相关问答