当前位置: 首页 > 工具软件 > book > 使用案例 >

Java Book类的设计

魏鹤轩
2023-12-01

Book类的设计

题目
阅读测试程序,设计一个Book类。

函数接口定义:
class Book{}
该类有四个私有属性分别是 书籍名称、价格、 作者、出版年份,以及相应的set 与get方法;该类有一个含有四个参数的构造方法,这四个参数依次是书籍名称、价格、作者、出版年份 。

输入样例
三体,100,无名氏,1998
上下五千年,50,编辑部,2015
海底世界,50,无名氏2,2000
三体1,100,无名氏3,2017
三体3,100,无名氏4,1998

输出样例
400

裁判测试程序样例


import java.util.*;
public class Main {
	public static void main(String[] args) {
		List <Book>books=new ArrayList<Book>();
		Scanner in=new Scanner(System.in);
		for(int i=0;i<5;i++)
		{	String str=in.nextLine();
			String []data=str.split(",");
			Book book=new Book(data[0],Integer.parseInt(data[1]),data[2],Integer.parseInt(data[3]));
			books.add(book);
		}
		
		System.out.println(totalprice(books));	
	}
	
	/*计算所有book的总价*/
	public static int totalprice(List <Book>books) 
	{  int result=0;
		for(int i=0;i<books.size();i++){result+=books.get(i).getPrice();}
		return result;
	}
}

/* 请在这里填写答案 */

答案

class Book{
 private String bname;
 private double price;
 private String name;
 private int year;
 public Book() {};
 public Book(String bname,double price,String name,int year)
 {
  this.bname=bname;
  this.price=price;
  this.name=name;
  this.year=year; 
 }
 public void setBname(String bn)
 {
  this.bname=bn;
 }
 public String getBname()
 {
  return bname;
 }
 public void setPrice(double p)
 {
  this.price=p;
 }
 public double getPrice()
 {
  return price;
 }
 public void setName(String n)
 {
  this.name=n;
 }
 public String getName()
 {
  return name;
 }
 public void setYear(int y)
 {
  this.year=y;
 }
 public int getYear()
 {
  return year;
 }
}
 类似资料: