当前位置: 首页 > 工具软件 > elevator.js > 使用案例 >

2.Elevator

施晗日
2023-12-01

(1)Problem Description

             The highest building in our city has only one elevator. A request list is made upwith N positive numbers. The numbers denote at which floors the elevator will stop, inspecified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds tomove down one floor. The elevator will stay for 5 seconds at each stop.For a given request list, you are to compute the total time spent to fulfill therequests on the list. The elevator is on the 0th floor at the beginning and does not haveto return to the ground floor when the requests are fulfilled.

  (2)Input

               There are multiple test cases. Each case contains a positive integer N, followed byN positive numbers. All the numbers in the input are less than 100. A test case with N= 0 denotes the end of input. This test case is not to be processed.

    (3)OutputPrint the total time on a single line for each test case.

    (4)Sample Input

1 2

3 2 3 1

0

     (5)Sample Output

17 (6 * 2 + 5)

41 (6 * 2 + 5 + 6 * 1 + 5 + 4 * 2 + 5)

//其实这道题很简单    题意:给出楼层将要停几次,每次停的楼层号,按规定的顺序,计算总时间(从0开始)。


向上移动一层6秒,向下移动一层4秒,电梯每次停的时候需要5秒。

输入0表示结束。






#include<iostream>
#include<string>
#include<sstream>
using namespace std;
int main()
{
	int n; //到达几个楼层
	cin >> n;
	int a[10];//楼层号

	while (n)
	{
		int i, sum = 0;//sum为所花费总时间

		if (n == 1)
		{
			cin >> a[0];
			sum = sum + (a[0] * 6 + 5);
			cout << sum << "(6*" << a[0] << "+5)" << endl;
			cin >> n;
		}
		

		else
		{
			for (i = 0; i < n; i++)
			{
				cin >> a[i];
			}

			sum = (a[0] * 6 + 5);

			for (i = 1; i < n; i++)
			{
				if (a[i] > a[i - 1])
				{
					sum = sum + ((a[i] - a[i - 1]) * 6 + 5);
				}
				
				else if (a[i] < a[i - 1])
				{
					sum = sum + ((a[i - 1] - a[i]) * 4 + 5);
				}
			}
			cout << sum << "(6*" << a[0] << "+5";
            for(i=1;i<n;i++)
			{

				if (a[i] > a[i - 1])
					cout << "+6*" << a[i]-a[i-1] << "+5";
				
				if(a[i]<a[i-1])
					cout << "+4*" << a[i-1] - a[i] << "+5";

			}
			cout << ")" << endl;
			cin >> n;
		}
	}

	return 0;
}

 类似资料: