当前位置: 首页 > 工具软件 > elevator.js > 使用案例 >

A、Elevator

舒嘉德
2023-12-01
Time Limit: 2 Seconds      Memory Limit: 65536 KB

How time flies! The graduation of this year is around the corner. N members of ZJU ACM/ICPC Team decided to hold a party in a restaurant. The restaurant is located in a skyscraper so they need to take an elevator to reach there.

The elevator's maximum load is M kilograms. The weight of the i-th team member isAi kilograms. If the total weight of people in the elevator exceeds the maximum load of the elevator, the elevator will raise the alarm and will not move.

Please write a program to implement the weight detector of the elevator.

Input

There are multiple test cases. The first line of input is an integer T indicates the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 20) andM (1 <= M <= 2000). The next line contains N integersAi (1 <= Ai <= 500).

Output

For each test case, output "Safe" if no alarm will be raised. Otherwise, output "Warning".

Sample Input

2
3 800
50 60 70
9 800
50 55 60 60 60 60 65 70 360

Sample Output

Safe
Warning
 
很顺利地一次AC
 
#include<iostream>
using namespace std;
long t,n,m,sum=0,x;
int main(){
	cin>>t;
	while(t--){
		cin>>n>>m;
		sum=0;
		while(n--){
			cin>>x;
			sum+=x;
		}
		if(sum>m)cout<<"Warning"<<endl;
		else cout<<"Safe"<<endl;
	}
}


 类似资料: