当前位置: 首页 > 工具软件 > CUP > 使用案例 >

HDU2289:Cup(二分)

袁泓
2023-12-01

 

Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?  

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

 

Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input
1 100 100 100 3141562
 

Sample Output
99.999024
 
题意:给出圆台的底面半径,顶部半径,高还有水的体积,求水的高度
思路:我们可以直到水的高度必然在0到最大高度之间,在这个区间内进行二分即可
 
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define exp 1e-9
double solve(double r,double R,double h,double H)
{
    double u = h/H*(R-r) + r;
    return PI/3*(r*r+r*u+u*u)*h;
}
int main()
{
    int t;
    double r,R,H,V,mid,vv,f,l;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf",&r,&R,&H,&V);
        f=0;
        l=100;
        while(l-f>exp)
        {
            mid=(l+f)/2;
            vv=solve(r,R,mid,H);
            if(fabs(vv-V)<=exp)
                break;
            else if(vv>V)
                l=mid-exp;
            else
                f=mid+exp;
        }
        printf("%.6lf\n",mid);
    }
    return 0;
}

 类似资料: