Time limit | Memory limit | OS |
---|---|---|
1000 ms | 65536 kB | Linux |
Jessica’s a very lovely girl wooed by lots of boys. Recently she has a
problem. The final exam is coming, yet she has spent little time on
it. If she wants to pass it, she has to master all ideas included in a
very thick text book. The author of that text book, like other
authors, is extremely fussy about the ideas, thus some ideas are
covered more than once. Jessica think if she managed to read each idea
at least once, she can pass the exam. She decides to read only one
contiguous part of the book which contains all ideas covered by the
entire book. And of course, the sub-book should be as thin as
possible.A very hard-working boy had manually indexed for her each page of
Jessica’s text-book with what idea each page is about and thus made a
big progress for his courtship. Here you come in to save your skin:
given the index, help Jessica decide which contiguous part she should
read. For convenience, each idea has been coded with an ID, which is a
non-negative integer.
Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is
the number of pages of Jessica’s text-book. The second line contains P
non-negative integers describing what idea each page is about. The
first integer is what the first page is about, the second integer is
what the second page is about, and so on. You may assume all integers
that appear can fit well in the signed 32-bit integer type.
Output
Output one line: the number of pages of the shortest contiguous part
of the book which contains all ideals covered in the book.
Sample Input
5
1 8 8 8 1
Sample Output
2
题意:给你一个数p表示有p个数,让你找出最短的长度,此长度包含所有出现过的数字
思路:用尺取法来做这道题,先找到符合的长度,然后通过增减长度来更新最小的长度
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#include<set>
#include<map>
using namespace std;
const int maxn=505;
const int inf=0x3f3f3f3f;
int v[1000005];
int main()
{
set<int>g;
map<int,int>q;
int p;
scanf("%d",&p);
for(int a=1;a<=p;a++)
{
scanf("%d",&v[a]);
g.insert(v[a]);
}
int n=g.size();
int s=1,e=1,minn=p,ant=0;
while(1)
{
while(e<=p&&ant<n)
{
if(q[v[e]]==0)
{
ant++;
}
q[v[e]]++;
e++;
}
if(ant<n)break;
minn=min(minn,e-s);
if(--q[v[s]]==0)
{
ant--;
}
s++;
}
printf("%d\n",minn);
return 0;
}