当前位置: 首页 > 工具软件 > River Trail > 使用案例 >

Cross the river

曹奇文
2023-12-01

Problem description:

Some people want to cross a river by boat. Each person has a weight, and each boat can carry a maximum weight of limit. Each boat carries at most 2 people at the same time, provided the sum of the weight of those people is at most limit. Return the minimum number of boats to carry every given person. Note that it is guaranteed each person can be carried by a boat.

Input:

The input will be 3 lines. The first line is a single integer n (1 <= n <= 50000), which means the number of people. The second line is a single integer l (1 <= l <= 30000), represents the weight limit. And the last line contains n integers p_1, p_2, …, p_n (1 <= p_i <= l), separated by spaces, that represent people’s weights.

Output:

The output will consist of one line containing one integer, which represents the minimum number of boats.

Sample Input:

4
3
3 2 2 1

Sample Output:

3
#include <iostream>
#include<algorithm>
using namespace std;

int main()
{
	int people[100000];
	int boat, num, i, j, weight, count = 0;
	cin >> num >> weight;
	for (i = 0; i < num; i++)
	{
		cin >> people[i];
	}

	sort(people, people + num);//从小到大排列
	i = 0; j = num-1;
	while (i<=j)//判断结束条件,每次从头尾各取一个,若和不小于船重量,则尾部大值减一扫描
	{
		if (i == j)//只剩最后一个人时候
		{
			count++;
			break;
		}
		if (people[i] + people[j] <= weight)
		{
			count++;
			i++;
			j--;

		}
		else
		{
			//当其超过则让大的单独做一个船,例如船重量为6
			//体重依次为2 3 4 5  7
			count++;
			j--;
		}
		
	}
   
	cout << count;
	return 0;
}

 

 类似资料:

相关阅读

相关文章

相关问答