当前位置: 首页 > 工具软件 > baidu yogurt > 使用案例 >

poj2393 Yogurt factory(贪心)

汤兴生
2023-12-01
Yogurt factory
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6836 Accepted: 3499

Description

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week. 

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. 

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

Input

* Line 1: Two space-separated integers, N and S. 

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS: 
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units. 
<strong style="background-color: rgb(0, 102, 0);">题目大意:每周价格会变动,再仓库储存会花钱,每周有个需求量,满足需求量求最少的花费,可以直接和上一周的最小花费与本周的递推比较就可以。</strong>
/*
没耐心读懂题,直接百度的。是不是有点浮躁呢?周末还好,能静下心来分析分析题,平时时间不多,等分析出来,花儿都谢了,虽然对题意理解会有提高,但还是懒得分析。
Time:2014-11-17 8:06
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=10000+10;
int main(){
	int N,s;
	int c[MAX],y[MAX];
	scanf("%d%d",&N,&s);
	__int64 ans=0;
	for(int i=0;i<N;i++){
		scanf("%d%d",&c[i],&y[i]);
	}	
	for(int i=1;i<N;i++){
		c[i]=min(c[i-1]+s,c[i]);
	}
	for(int i=0;i<N;i++){
		ans+=c[i]*y[i];
	}
	printf("%I64d\n",ans);
return 0;
}

 类似资料: