当前位置: 首页 > 工具软件 > knight > 使用案例 >

Traveling Knight Problem

薛淳
2023-12-01

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the ”difficult” part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input:

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a..h) representing the column and a digit (1..8) representing the row on the chessboard.

Output:

For each test case, print one line saying ‘To get from xx to yy takes n knight moves.’.

Sample Input:

e2 e4

a1 b2

b2 c3

a1 h8

a1 h7

h8 a1

b1 c3

f6 f6

Sample Output:

To get from e2 to e4 takes 2 knight moves.

To get from a1 to b2 takes 4 knight moves.

To get from b2 to c3 takes 2 knight moves.

To get from a1 to h8 takes 6 knight moves.

To get from a1 to h7 takes 5 knight moves.

To get from h8 to a1 takes 6 knight moves.

To get from b1 to c3 takes 1 knight moves.

To get from f6 to f6 takes 0 knight moves.

题意:给一个8*8的图,行为1~8,列为a~b。每组数据给出两个坐标位置,求从前面的坐标走到后面的坐标最少需要几步。

         所走的路线必须是“日”字。就如国际象棋中马走日一样。

题解:简单的广搜题。

第一次不在任何人的帮助下AC题。超级开森*-**-**-*

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int p,q,book[100][100],n,m;
char a,b;
int dir[8][2]={{-1,2},{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1},{-2,1}};
struct node
{
    int x;
    int y;
    int step;
};
void bfs(int x,int y,int step)
{
    memset(book,0,sizeof(book));
    queue<node>Q;
    node now,next;
    book[x][y]=1;
    now.x=x;
    now.y=y;
    now.step=step;
    Q.push(now);
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        if(now.x==q&&now.y==m)
        {
            printf("To get from %c%d to %c%d takes %d knight moves.\n",a,n,b,m,now.step);
            return ;
        }
        for(int k=0;k<8;k++)
        {
            int tx=now.x+dir[k][0];
            int ty=now.y+dir[k][1];
            if(tx<1||ty<1||tx>8||ty>8||book[tx][ty])
                continue;
            if(book[tx][ty]==0)
            {
                book[tx][ty]=1;
                next.x=tx;
                next.y=ty;
                next.step=now.step+1;
                Q.push(next);
            }
        }
    }
}
int main()
{
    while(~scanf("%c%d %c%d",&a,&n,&b,&m))
    {
        getchar();
        memset(book,0,sizeof(book));
        p=a-'a'+1;
        q=b-'a'+1;
        bfs(p,n,0);
    }
    return 0;
}

 

 类似资料:

相关阅读

相关文章

相关问答