#1135 : Magic Box
时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述
The circus clown Sunny has a magic box. When the circus is performing, Sunny puts some
balls into the box one by one. The balls are in three colors: red(R), yellow(Y) and
blue(B). Let Cr, Cy, Cb denote the numbers of red, yellow, blue balls in the box.
Whenever the differences among Cr, Cy, Cb happen to be x, y, z, all balls in the box
vanish. Given x, y, z and the sequence in which Sunny put the balls, you are to find
what is the maximum number of balls in the box ever.
For example, let's assume x=1, y=2, z=3 and the sequence is RRYBRBRYBRY. After Sunny puts
the first 7 balls, RRYBRBR, into the box, Cr, Cy, Cb are 4, 1, 2 respectively. The
differences are exactly 1, 2, 3. (|Cr-Cy|=3, |Cy-Cb|=1, |Cb-Cr|=2) Then all the 7 balls
vanish. Finally there are 4 balls in the box, after Sunny puts the remaining balls. So the
box contains 7 balls at most, after Sunny puts the first 7 balls and before they vanish.
输入
Line 1: x y z
Line 2: the sequence consisting of only three characters 'R', 'Y' and 'B'.
For 30% data, the length of the sequence is no more than 200.
For 100% data, the length of the sequence is no more than 20,000, 0 <= x, y, z <= 20.
输出
The maximum number of balls in the box ever.
提示
Another Sample
Sample Input | Sample Output |
---|---|
0 0 0 | |
RBYRRBY | 4 |
样例输入
1 2 3
RRYBRBRYBRY
样例输出
7
C语言:
//cr,cy,cb三个差值等于x,y,z即可,无需考虑顺序
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
int yxh(const void *p1,const void *p2)
{
return *(int *)p1-*(int *)p2;
}
int main()
{
int cr,cy,cb,a[3],b[3],i,max;
char s[20001];
scanf("%d%d%d",&a[0],&a[1],&a[2]);
scanf("%s",&s);
qsort(a,3,sizeof(int),yxh);//快排
for(i=cr=cy=cb=max=0; s[i]!='\0'; i++)
{
if(s[i]=='R')
{
cr++;
}
else if(s[i]=='Y')
{
cy++;
}
else if(s[i]=='B')
{
cb++;
}
b[0]=abs(cr-cy);
b[1]=abs(cr-cb);
b[2]=abs(cy-cb);
qsort(b,3,sizeof(int),yxh);//快排
if(a[0]==b[0]&&a[1]==b[1]&&a[2]==b[2])
{
if(max<cr+cy+cb)
{
max=cr+cy+cb;
}
cr=cy=cb=0;
}
}
if(max<cr+cy+cb)
{
max=cr+cy+cb;
}
printf("%d",max);
}