当前位置: 首页 > 工具软件 > Rainbows! > 使用案例 >

Colorful Rainbows(计算几何)

和飞翔
2023-12-01
C - Colorful Rainbows
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Evelyn likes drawing very much. Today, she draws lots of rainbows on white paper of infinite size, each using a different color. Since there're too many rainbows now, she wonders, how many of them can be seen?

For simplicity, each rainbow Li is represented as a non-vertical line specified by the equation: y=aix+bi. A rainbow Li can be seen if there exists some x-coordinate x0 at which, its y-coordinate is strictly greater than y-coordinates of any other rainbows: aix0+bi > ajx0+bjfor all j != i.

Now, your task is, given the set of rainbows drawn, figure out the number of rainbows that can be seen.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 60) which is the number of test cases. And it will be followed by T consecutive test cases.

There's a blank line before every case. In each test case, there will first be an integer n (1 <= n <= 5000), which is the number of rainbows. Then n consecutive real number pairs follow. Each pair contains two real numbers, ai and bi, representing rainbow Li: y=aix+bi. No two rainbows will be the same, that is to say, have the same a and b.

Output

Results should be directed to standard output. The output of each test case should be a single integer, which is the number of rainbows that can be seen.

Sample Input

2

1
1 1

3
1 0
2 0
3 0

Sample Output

1
2
 
   
思路:
这题其实就是根据斜率大小来排序,之后就能根据两条线交点的x轴每次都要小于下一次就能不被以前的线段覆盖了,之后剩下的直线就是没被覆盖的了。
剩下在栈的元素都是X1<X2<X3....<Xn的,只有这样才能让所加直线不被覆盖掉。
 
   
AC代码:
 
   
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<stack>
using namespace std;
#define T 10000
#define inf 0x3f3f3f3f
struct node
{
	double k,b,x;
	bool operator<(const node& a)const{
		return k<a.k||(k==a.k&&b<a.b);
	}
}a[T],t[T];
int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif
	int n,m,i;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&m);
		for(i=0;i<m;++i){
			scanf("%lf%lf",&a[i].k,&a[i].b);
		}
		sort(a,a+m);
		int c = 0;
		for(i=0;i<m-1;++i){//去重
			if(a[i].k!=a[i+1].k)t[c++]=a[i];
		}
		if(t[c-1].k!=a[m-1].k){
			t[c++] = a[m-1];
		}
		else
		{
			t[c-1] = a[m-1];
		}
		stack<node> s;
		t[0].x = -inf;
		node tmp;
		s.push(t[0]);
		int top;
		for(i=1;i<c;++i){
			while(true){
				tmp = s.top();
			double x = (tmp.b-t[i].b)/(t[i].k-tmp.k);
				if(tmp.x<x){
					t[i].x = x;
					s.push(t[i]);break;
				}
				else
				{
					s.pop();
				}
			}
		}
		printf("%d\n",s.size());
	}
	return 0;
}


 类似资料: