当前位置: 首页 > 工具软件 > Aladdin lamp > 使用案例 >

LightOJ 1341 Aladdin and the Flying Carpet

申屠项明
2023-12-01

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

题目大意:对于c*d==a的二元数组有多少?限制条件(c>=b&&d>=b)

注意:(c,d)和(d,c)一样,为一组满足。

思路:唯一分解定理:任何一个大于1的自然数 N,如果N不为质数N = p1^a1*p2^a2*p3^a3* ... *pn^an(其中p1、p2、... pn为N的因子,a1、a2、... 、an分别为因子的指数) N的因子个数M = (1 + a1)*(1 + a2)*(1 + a3)*...*(1 + an);

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
ll su[80000],book[1000010];
ll ans=1;
ll r=0;
void prime()
{
    memset(book,0,sizeof(book));
    book[0]=book[1]=1;
    for(ll i=2; i<1000010; i++)
    {
        if(!book[i])
        {
            su[r++]=i;
            for(ll j=i*2; j<1000010; j+=i)
                book[j]=1;
        }
    }
}
ll solve(ll a)
{
    for(int i=0; i<r&&a; i++)
    {
        if(su[i]>a)
            break;
        long long num=0;
        while(a%su[i]==0)
        {
            a/=su[i];
            num++;
        }
        ans*=(1+num);
    }
    if(a>1)//**********
        ans*=2;
    return ans;
}
int main()
{
    int c;
    prime();
    int o=1;
    scanf("%d",&c);
    while(c--)
    {
        ll a,b;
        ans=1;
        scanf("%lld%lld",&a,&b);
        if(b*b>a)
        {
            printf("Case %d: 0\n",o++);
            continue;
        }
        solve(a);
        ans/=2;
        for(ll i=1; i<b; i++)
        {
            if(a%i==0)
                ans--;
        }
        printf("Case %d: %lld\n",o++,ans);
    }
    return 0;
}

 

 类似资料:

相关阅读

相关文章

相关问答