当前位置: 首页 > 工具软件 > Aladdin lamp > 使用案例 >

Aladdin and the Flying Carpet(唯一分解定律)

周涵畅
2023-12-01

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output
For each case, print the case number and the number of possible carpets.

Sample Input

2
10 2
12 2

Sample Output

Case 1: 1
Case 2: 2

题意:给出一个面积和围成这个面积的最小边,求出共有几种情况(每种情况的边长必须大于或等于这个最小边,且围成的为长方形)

思路:根据唯一分解定理:任何一个大于1的自然数 N,如果N不为质数,那么N可以唯一分解成有限个质数的乘积N=P1a1P2a2P3a3…Pnan,这里P1<P2<P3…<Pn均为质数,其中指数ai是正整数。先将a唯一分解,则a的所有正约数的个数为num = (1 + a1) * (1 + a2) *…(1 + ai),这里的ai是素因子的指数,见唯一分解定理,因为题目说了不会存在c==d的情况,因此num要除2,去掉重复情况,然后枚举小于b的a的约数,拿num减掉就可以了

代码:

#include"stdio.h"
long long p[1000010],s[1000010];
int main()
{
	long long i,j,l=0;
    s[1]=1;
    for(i=2;i<=1000000;i++)
    {
        if(!s[i])
        {
            p[l++]=i;
            for(j=2;i*j<=1000000;j++)
            s[i*j]=1;
        }
    }
    int t,k=1;
    scanf("%d",&t);
    while(t--)
    {
    	long long a,b,ans=0,sum=1,n;
        scanf("%lld %lld",&a,&b);
        n=a;
        if(a<b*b)
        {
            printf("Case %d: 0\n",k++);
            continue;
        }
    	for(i=0;i<l&&p[i]*p[i]<=n;i++)
    	{
       		if(n%p[i]==0)
        	{
         		ans=0;
         		while(n%p[i]==0)
          		{
             		ans++;
              		n/=p[i];
            	}
            	sum*=(1+ans);
        	}
    	}
    	if(n>1)//如果n不能被整分,说明还有一个素数是它的约数,此时ans=1
    	sum*=2;
        sum/=2;
        for(i=1;i<b;i++)
        if(a%i==0)
        sum--;
        printf("Case %d: %lld\n",k++,sum);
    }
    return 0;
}
 类似资料: