当前位置: 首页 > 工具软件 > Minesweeper > 使用案例 >

问题 1096: Minesweeper

彭胡媚
2023-12-01

原题目链接-蓝桥杯练习题目

问题 1096: Minesweeper

时间限制: 1Sec 内存限制: 64MB 提交: 2759 解决: 1128

题目描述
Minesweeper Have you ever played Minesweeper? This cute little game comes with a certain operating system whose name we can’t remember. The goal of the game is to find where all the mines are located within a M x N field. The game shows a number in a square which tells you how many mines there are adjacent to that square. Each square has at most eight adjacent squares. The 4 x 4 field on the left contains two mines, each represented by a *'' character. If we represent the same field by the hint numbers described above, we end up with the field on the right: *... .... .*.. .... *100 2210 1*10 1110 输入 The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m ( 0 < n, m$ \le$100) which stand for the number of lines and columns of the field, respectively. Each of the next n lines contains exactly m characters, representing the field. Safe squares are denoted by.’’ and mine squares by *,'' both without the quotes. The first field line where n = m = 0 represents the end of input and should not be processed. 输出 For each field, print the message Field #x: on a line alone, where x stands for the number of the field starting from 1. The next n lines should contain the field with the.’’ characters replaced by the number of mines adjacent to that square. There must be an empty line between field outputs.
样例输入
4 4


.


3 5
**…

.*…
0 0
样例输出
Field #1:
100
2210
1
10
1110

Field #2:
**100
33200
1*100

注意判断边界条件即可

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
  int n, m;
  char a[100][100];
  char s[100][100];
  int field = 1;
  while(scanf("%d %d", &n, &m) != EOF)
  {
    if(n == 0 || m == 0) break;
    for(int i=0;i<n;i++)
      scanf("%s", s[i]);
    for(int i=0;i<n;i++)
    {
      for(int j=0;j<m;j++)
      {
        if(s[i][j] == '*')
        {
          a[i][j] = '*';
          continue;
        }
        int cnt = 0;
        if(i-1>=0 && s[i-1][j] == '*')
          ++cnt;
        if(j-1>=0 && s[i][j-1] == '*')
          ++cnt;
        if(i+1<=n && s[i+1][j] == '*')
          ++cnt;
        if(j+1<=m && s[i][j+1] == '*')
          ++cnt;
        if(i-1>=0 && j-1>=0 && s[i-1][j-1] == '*')
          ++cnt;
        if(i-1>=0 && j+1<=m && s[i-1][j+1] == '*')
          ++cnt;
        if(i+1<=n && j-1>=0 && s[i+1][j-1] == '*')
          ++cnt;
        if(i+1<=n && j+1<=m && s[i+1][j+1] == '*')
          ++cnt;
        a[i][j] = '0' + cnt;
      }
    }
    printf("Field #%d:\n", field);
    for(int i=0;i<n;i++)
    {
      cout<<a[i]<<endl;
    }
    ++field;
    cout<<endl;
  }
  return 0;
}

 类似资料: