当前位置: 首页 > 工具软件 > EasyTask > 使用案例 >

HDOJ1076 An Easy Task

孟和怡
2023-12-01

An Easy Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24613    Accepted Submission(s): 15866


Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 

Output
For each test case, you should output the Nth leap year from year Y.
 

Sample Input
3 2005 25 1855 12 2004 10000
 

Sample Output
2108 1904 43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
  给出其实年份,求该年份的第N个闰年,计算闰年的方法都给了
import java.util.Scanner;

public class Main{
	private static Scanner scanner;
	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		int cases = scanner.nextInt();
		while(cases-->0){
			int year = scanner.nextInt();
			int m = scanner.nextInt();
			int count = 0,i = 0;
			while(count<m){
				if(judgeYear(year+i)){
					count++;
				}
				i++;
			}
			System.out.println(year+i-1);
		}
	}
	private static boolean judgeYear(int i) {
		if((i%4==0 && i%100!=0 )|| i%400 == 0){
			return true;
		}
		return false;
	}
}


 类似资料:

相关阅读

相关文章

相关问答