An Easy Task
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19001 Accepted Submission(s): 12148
Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?
Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.
Note: if year Y is a leap year, then the 1st leap year is year Y.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
Output
For each test case, you should output the Nth leap year from year Y.
Sample Input
3
2005 25
1855 12
2004 10000
Sample Output
2108
1904
43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
给出开始的年份Y,问第N 个闰年是哪一年
唯一能想到的办法就是循环暴力枚举,想想会超时,然后再上网搜解法,继而发现神奇的与闰年相关的结论,没想到...暴力竟然AC了, 然后瞬间感觉自己想多了........
#include<stdio.h>
#include<string.h>
bool leap(int x)
{
return x%4==0&&x%100!=0||x%400==0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int y,n;
scanf("%d%d",&y,&n);
while(n)
{
if(leap(y))
{
--n;
}
++y;
}
printf("%d\n",y-1);
}
return 0;
}