当前位置: 首页 > 工具软件 > Posterita POS > 使用案例 >

「1138」Postorder Traversal

徐涵亮
2023-12-01

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

Ω

给出前序、中序遍历,输出后序遍历第一个元素。根据后序遍历的定义,第一个元素是整棵树最左边那个没有子节点的节点。那么递归顺序就很显然了,如果存在左子树就递归左子树,没有就递归右子树,直到没有子树的节点为止。子树的划分就不多说了,详情看traversal order的tag。


#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;
vector<int> pre, in;

int first_post(int ps, int pe, int is, int ie)
{
    if (ps == pe) return pre[ps];
    int bias = find(in.begin() + is, in.begin() + ie, pre[ps]) - in.begin() - is;
    if (bias > 0) return first_post(ps + 1, ps + bias, is, is + bias - 1);
    else return first_post(ps + bias + 1, pe, is + bias + 1, ie);
}

int main()
{
    int n;
    cin >> n;
    pre.resize(n), in.resize(n);
    for (auto &k: pre) cin >> k;
    for (auto &k: in) cin >> k;
    cout << first_post(0, n - 1, 0, n - 1);
}
 类似资料:

相关阅读

相关文章

相关问答