当前位置: 首页 > 工具软件 > Marble > 使用案例 >

第七十四题 UVA10474 大理石在哪儿 Where is the Marble?

贡斌
2023-12-01

Raju and Meena love to play with Marbles. They have got a lot of
marbles with numbers written on them. At the beginning, Raju would
place the marbles one after another in ascending order of the numbers
written on them. Then Meena would ask Raju to find the first marble
with a certain number. She would count 1…2…3. Raju gets one point
for correct answer, and Meena gets the point if Raju fails. After some
fixed number of trials the game ends and the player with maximum
points wins. Today it’s your chance to play as Raju. Being the smart
kid, you’d be taking the favor of a computer. But don’t underestimate
Meena, she had written a program to keep track how much time you’re
taking to give all the answers. So now you have to write a program,
which will help you in your role as Raju.
Input
There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins
with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next
N lines would contain the numbers written on the N marbles. These marble numbers will not come
in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers
are greater than 10000 and none of them are negative.
Input is terminated by a test case where N = 0 and Q = 0.
Output
For each test case output the serial number of the case.
For each of the queries, print one line of output. The format of this line will depend upon whether
or not the query number is written upon any of the marbles. The two different formats are described
below:
• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered
1, 2, . . . , N.
• ‘x not found’, if the marble with number x is not present.
Look at the output for sample input for details.
Sample Input
4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0
Sample Output
CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

【分析】
C++ algorithm库函数,lower_bound秒过,我就当做复习一下二分了吧,我那种写个Ans = Mid的写法,是我这么多年一直这么写的,从没翻车,但是今天出了点小状况 他并不保证是最靠左的,所以有个while。。。。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define Maxn 10005
using namespace std;

int a[Maxn],n,m;

inline int Find(int x) {
	int Mid,l = 1, r = n,Ans;
	while(l <= r) {
		Mid = l + r >> 1; 
		if(a[Mid] <= x) Ans = Mid,l = Mid + 1;
		else r = Mid - 1;
	}
	while(a[Ans - 1] == a[Ans]) Ans--;
	
	return Ans;
}


int main(int argc,char* argv[]) {
	int kase = 0;
	while(scanf("%d %d",&n,&m) == 2 && n) {
		
		for(int i=1; i<=n; i++) scanf("%d",&a[i]);
		sort(a + 1,a + n + 1);
		printf("CASE# %d:\n",++kase);
		for(int x,i=1; i<=m; i++) {
			scanf("%d",&x);
			int Ans = Find(x);
			if(a[Ans] == x) printf("%d found at %d\n",x,Ans);
			else printf("%d not found\n",x);
		}
	}
	
	
	return 0;
}
 类似资料: