Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.
Input
The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1…M), and no stall will be listed twice for a given cow.
Output
For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.
Sample Input
5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2
Sample Output
4
题意 给你5个牛和牛棚 1号棚有两头牛愿意入住产奶 分别是2号和5号 2号棚有3头牛愿意入住产奶 分别·是2,3,4号。。。。求最大产奶量
分析 这就是最大匹配问题 用二分图可以做
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int e[220][220],n,m,a[220],book[220];
int dfs(int u)
{
int i;
for(int i=1;i<=m;i++)
{
if(e[u][i]&&!book[i]) ///u是愿意在i牛棚,且牛棚在本次搜索中为空
{
book[i]=1; ///注意:book标记与a[i]记录的不同
if(a[i]==0||dfs(a[i])) ///牛棚是否为空,若不为空 判断是否去别处
{
a[i]=u; /// 记录i号牛棚入住u号牛
return 1;
}
}
}
return 0;
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(e,0,sizeof(e));
int t1,t2;
for(int i=1;i<=n;i++)
{
scanf("%d",&t1);
for(int j=1;j<=t1;j++)
{
scanf("%d",&t2);
e[i][t2]=1; ///i号牛愿意在t2号牛棚产奶
}
}
int sum=0;
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++) ///为i号牛寻找牛棚
{
memset(book,0,sizeof(book));
if(dfs(i))
sum++; ///牛i找到牛棚
}
printf("%d\n",sum);
}
return 0;
}