当前位置: 首页 > 工具软件 > Final Term > 使用案例 >

PAT 甲级 1137  Final Grading

邵毅
2023-12-01

1137 Final Grading (25 point(s))

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(G​mid−term​​×40%+G​final​​×60%) if G​mid−term​​>G​final​​, or G​final​​ will be taken as the final grade G. Here G​mid−term​​ and G​final​​ are the student's scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores G​p​​'s; the second one contains M mid-term scores G​mid−term​​'s; and the last one contains N final exam scores G​final​​'s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID G​p​​ G​mid−term​​ G​final​​ G

If some score does not exist, output "−1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qullified student.

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

经验总结:

emmmm  注意round up to是四舍五入,不是向上取整,虽然它两个意思都有,但是从测试用例可以推知是第一重含义,存储方面,我是采用map映射学生的序号进行存储,最后再对存储的所有学生进行排序,输出最后结果即可~

AC代码

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <string>
#include <map>
using namespace std;
const int maxn=10010;
int n,m,p,t;
char s[maxn];
struct student
{
	int Gp,Gm,Gf,G;
	bool f;
	char id[25];
	student():Gm(-1),f(false){}
}stu[maxn];
bool cmp(student a,student b)
{
	if(a.f!=b.f)
		return a.f>b.f;
	if(a.G!=b.G)
		return a.G>b.G;
	return strcmp(a.id,b.id)<0;
}
int rround(double a)
{
	return (int)floor(a+0.5);
}
int main()
{
	char temp[25];
	int num=0,rnum=0;
	map<string,int> mp;
	scanf("%d%d%d",&p,&m,&n);
	for(int i=0;i<p;++i)
	{
		scanf("%s%d",temp,&t);
		if(t>=200)
		{
			if(mp.count(temp)==0)
				mp[temp]=num++;
			strcpy(stu[mp[temp]].id,temp);
			stu[mp[temp]].Gp=t;
		}
	}
	for(int i=0;i<m;++i)
	{
		scanf("%s%d",temp,&t);
		if(mp.count(temp)!=0)
			stu[mp[temp]].Gm=t;
	}
	for(int i=0;i<n;++i)
	{
		scanf("%s%d",temp,&t);
		if(mp.count(temp)!=0)
		{
			if(t>=stu[mp[temp]].Gm)
				stu[mp[temp]].G=t;
			else
				stu[mp[temp]].G=rround(0.4*stu[mp[temp]].Gm+0.6*t);
		}
		if(stu[mp[temp]].G>=60)
		{
			stu[mp[temp]].f=true;
			++rnum;
		}
		stu[mp[temp]].Gf=t;
	}
	sort(stu,stu+num,cmp);
	for(int i=0;i<rnum;++i)
		printf("%s %d %d %d %d\n",stu[i].id,stu[i].Gp,stu[i].Gm,stu[i].Gf,stu[i].G);
	return 0;
}

 

 类似资料: