2017杭电多校第四场 1009 Questionnaire HDU 6075

魏翰
2023-12-01

Questionnaire

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 23    Accepted Submission(s): 17
Special Judge


Problem Description
In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.

Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer  ai  to represent his opinion. When finished, the leader will choose a pair of positive interges  m(m>1)  and  k(0k<m) , and regard those people whose number is exactly  k  modulo  m  as ''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training.

Please help the team leader to find such pair of  m  and  k .
 

Input
The first line of the input contains an integer  T(1T15) , denoting the number of test cases.

In each test case, there is an integer  n(3n100000)  in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are  n  distinct integers  a1,a2,...,an(1ai109) , denoting the number that each person chosen.
 

Output
For each test case, print a single line containing two integers  m  and  k , if there are multiple solutions, print any of them.
 

Sample Input
1 6 23 3 18 8 13 9
 

Sample Output
5 3
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6079  6078  6077  6076  6075 
m=2时都满足情况

#include <cstdio>
int main()
{
    int T,n,a,sum1,sum2;
    scanf("%d", &T);
    while(T--)
    {
        sum1=sum2=0;
        scanf("%d", &n);
        while(n--)
        {
            scanf("%d",&a);
            if(a&1) sum2++;
            else sum1++;
            }
         if(sum1>=sum2)
                printf("%d %d\n",2,0);
         else     printf("%d %d\n",2,1);
        }
    return 0;
}


 类似资料: