当前位置: 首页 > 工具软件 > yue-library > 使用案例 >

PAT-1022-Digital Library

邵博艺
2023-12-01

1022. Digital Library (30)


CHEN, Yue

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found
【解析】
这道题其实需要用到map来进行标记,只要是属于那个下标的都要输出所以我们可以用到map<string,set<int>>.题目大意就是给你n本书的情况,然后叫你进行m次查询,
然后输出该信息的书编号,如果没有这本书就输出not found比如说给你一个作者,然后会叫你输出这个作者的所有书。输入查询的时候,比如说输入1:The Testing Book
意思就是输入的是书的名字,然后输出的编号就是1111111和2222222。模仿网上的代码。之前一直没思路。
#include <iostream>
#include <cstdio>
#include <map>
#include <set>
using namespace std;
map<string, set<int> > title, author,publish,year,key;
void facs(map< string, set<int> > &p, string &s) {
    if(p.find(s) != p.end())
        {
        for(set<int>::iterator it = p[s].begin(); it != p[s].end(); it++)
            printf("%07d\n", *it);
       }
    else
    {
       printf("Not Found\n");
    }
}
int main() {
    int i,n,m;
    int id,num;
    scanf("%d", &n);
    string a,b,c,d,e,s;
    for(int i = 0; i < n; i++) {
        scanf("%d", &id);
        getchar();
        getline(cin,a);
        title[a].insert(id);
        getline(cin,b);
        author[b].insert(id);//分别采取信息,编号放入其中
        while(cin >>c)
            {
            key[c].insert(id);
            char s;
            s= getchar();
            if(s== '\n') break;
        }
        getline(cin,d);
        publish[d].insert(id);
        getline(cin, e);
        year[e].insert(id);
    }
    scanf("%d", &m);
    for(int i = 0; i < m; i++) {
        scanf("%d: ", &num);
        getline(cin, s);
        cout << num << ": " << s<< "\n";
        if(num == 1)
            facs(title, s);
        else if(num == 2)
        facs(author, s);
        else if(num == 3)
        facs(key, s);
        else if(num == 4)
        facs(publish,s);
        else if(num ==5)
        facs(year, s);
    }
    return 0;
}


 
 类似资料:

相关阅读

相关文章

相关问答