当前位置: 首页 > 工具软件 > bcoin > 使用案例 >

Coin Change

李法
2023-12-01

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19678    Accepted Submission(s): 6879


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
11 26
 

Sample Output
4 13
 

Author
Lily
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1171  1398  1085  1028  2152 
 
#include<stdio.h>
#include<string.h>
#include<math.h>
//#include<stdlib.h>
#include<algorithm>
#include<iostream>
const int maxn=410;
int b[6]= {1,5,10,25,50};
int main() {
    int i,j,k,g,f;
    int n;
    while(scanf("%d",&n)!=EOF) {
        int ans=0,t,m=100;
        for(i=0; i<=n; i++) {
            for(j=0; j<=(n-i*b[0])/b[1]; j++) {
                for(k=0; k<=(n-i*b[0]-j*b[1])/b[2]; k++) {
                    for(g=0; g<=(n-i*b[0]-j*b[1]-k*b[2])/b[3]; g++) {
                        for(f=0; f<=(n-i*b[0]-j*b[1]-k*b[2]-g*b[3])/b[4]; f++) {
                            if(n-i*b[0]-j*b[1]-k*b[2]-g*b[3]-f*b[4]==0&&(i+j+k+g+f)<=m)
                                ans++;
                        }
                    }
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 类似资料:

相关阅读

相关文章

相关问答