当前位置: 首页 > 工具软件 > bcoin > 使用案例 >

False coin

穆宏胜
2023-12-01

Problem Description

The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
**In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded. **
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.

Input

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: ‘<’, ‘>’, or ‘=’. It represents the result of the weighting:
‘<’ means that the weight of coins in the left pan is less than the weight of coins in the right pan,
‘>’ means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
‘=’ means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

Output

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input**

    5 3
    2 1 2 3 4
    <  
    1 1 4
    =
    1 2 5
    =

Sample Output

3

由题可知假币的质量始终大于或小于真币的质量所以我们把质量大的比较一次加一个单位反之减去一个单位,把最终值与sum比较

#include<stdio.h>
#include<string.h>
int z[1010];
int v[1000];
int p[1000];
int sum;   //用于判断假币总共比较几次;
int main()
{
    int a,b,c;
    char ch;
    while(~scanf("%d%d",&a,&b))
    {
        memset(p,0,sizeof(p));
        memset(v,0,sizeof(v));
        sum=0;
        while(b- -)
        {
            scanf("%d",&c);
            for(int j=0; j<2*c; j++)
                scanf("%d",&z[j]);
            getchar();
            scanf("%c",&ch);
            if(ch=='<')
            {
                sum++;
                for(int j=0; j<c; j++)
                    v[z[j]]--;
                for(int j=c; j<2*c; j++)
                    v[z[j]]++;
            }
            else if(ch=='>')
            {
                sum++;
                for(int j=0; j<c; j++)
                    v[z[j]]++;
                for(int j=c; j<2*c; j++)
                    v[z[j]]--;
            }
            else if(ch=='=')//说明这一部分全部为真币把其标记为1;
            {
                for(int j=0; j<2*c; j++)
                    p[z[j]]=1;
            }
        }
        int flag=0,k;
        for(int i=1; i<=a; i++)
        {
            if(p[i]= =0)
            {
                if(v[i]= =sum || v[i]= =-sum)
                {
                    k=i;      //记录假币的位置
                    flag++;
                }
            }
        }
        if(flag==1)
            printf("%d\n",k);
        else
            printf("0\n");
    }
    return 0;
}

诚实为本,切勿抄袭,实践才是检验真理的唯一标准;

 类似资料:

相关阅读

相关文章

相关问答