File Transfer

李泓
2023-12-01

We have a network of computers and a list of bi-directional connections.Each of these connections allows a file transfer from one computer to another. Is is possible to send a file from any computer on the network to any other.

Input Specification:
Each input file contains one test case.For each test,the first line contains N,the total number of computers in network.Each computer in the network is then repressented by a positive integer between 1 and N.then in the following lines,the input is given in the format:
I c1 c2:
where I stands for inputting a connection between c1 and c2;
or
C c1 c2:
where C stands for checking if it is possible to transfer files between c1 and c2;
or
S
where S stands for stopping this case.

Output Specification:
For each C case,print in one line the word “yes” or “no” if it is possible to transfer files bentween c1 and c2,respectively.At the end of each case,print int one line “The network is connected.”if there is a path between any pair of computers;or “There are k component.”where k is the number of connected components in this network;
Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:
no
no
yes
There are 2 components.

Sample Input 2:
5
C 3 2
I 3 2
C 1 5

#include <stdio.h>
#include <stdlib.h>


#define MAXSIZE 10001


int FindSetRoot(int  setType[] ,int X){



//  for(;haffumanArr[X]>0;X=haffumanArr[X]);
//  
//  return X; 



    if(setType[X]<0){
       return X; 
    } else{
       return  setType[X]= FindSetRoot(setType,setType[X]); 
    } 

}

void Union(int setType[],int root1,int root2){

//  setType[root1]=root2; 

    if(setType[root2]<setType[root1]){//root2高 

        setType[root2] += haffumanArr[root1];
        setType[root1] = root2;
    }else{//root2 高 
        setType[root1] += haffumanArr[root2];
        setType[root2] = root1;
    }   

} 


void Input_connection( int setType[] )
{ 
    int x1,x2;
    scanf("%d %d\n",&x1,&x2);
    int root1,root2;
    root1= FindSetRoot(setType,x1-1);
    root2 = FindSetRoot(setType,x2-1); 

    if(root1!=root2)
         Union(setType,root1,root2);
}

void Check_connection( int setType[]  )
{ 
    int x1,x2;
    scanf("%d %d\n",&x1,&x2);
    int root1,root2;
    root1= FindSetRoot(setType,x1-1);
    root2 = FindSetRoot(setType,x2-1); 

    if(root1==root2)
        printf("yes\n");
    else 
        printf("no\n");

}

int main(){

    int n;
    char in ;
    int setType[MAXSIZE];

    scanf("%d",&n); 
    for(int i=0;i<n;i++){
        setType[i]=-1; 
    } 
    int counter = 0;

    do{
        scanf("%c", &in);
        switch (in) {
            case 'I': Input_connection( setType); break;
            case 'C': Check_connection( setType); break;

        }

    }while(in!='S'); 

    for (int i=0; i<n; i++) {
            if ( setType[i] < 0 ) counter++;
    }
    if ( counter == 1 )
        printf("The network is connected.\n");
    else
        printf("There are %d components.\n", counter);

     return 0;
} 
 类似资料:

相关阅读

相关文章

相关问答