题目
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.
For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.
Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
Sample Input
11
26
Sample Output
4
13
题意:有五种面值的硬币,支付已知价格时有几种方案。
思路:暴力枚举(动态规划也挺好的,不过我不会写。。。)
#include <stdio.h>
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int ans=0; //abcde分别表示面值为50、25、10、5、1的硬币的个数
for(int a=0;a<=5;a++) //abcd的范围是通过“each one consisting of a number ( ≤250 ) for the amount of money in cents.”这句话来确定的,需要支付的价格不会超过250
for(int b=0;b<=10-2*a;b++)
for(int c=0;c<=25-5*a;c++)
for(int d=0;d<=50-2*c;d++)
for(int e=0;e<=100;e++) //e的范围是通过“Your program should be able to handle up to 100 coins. ”来确定的
if(50*a+25*b+10*c+5*d+e==n&&a+b+c+d+e<=100) //如果当前总价格与输入的价格相同且硬币总个数小于等于100,则满足题意,方案数加一
ans++;
printf("%d\n",ans);
}
return 0;
}