The Sultan of Nubia has no children, so she has decided that the country will be split into up to k
separate parts on her death and each part will be inherited by whoever performs best at some test. It
is possible for any individual to inherit more than one or indeed all of the portions. To ensure that
only highly intelligent people eventually become her successors, the Sultan has devised an ingenious
test. In a large hall filled with the splash of fountains and the delicate scent of incense have been
placed k chessboards. Each chessboard has numbers in the range 1 to 99 written on each square and is
supplied with 8 jewelled chess queens. The task facing each potential successor is to place the 8 queens
on the chess board in such a way that no queen threatens another one, and so that the numbers on
the squares thus selected sum to a number at least as high as one already chosen by the Sultan. (For
those unfamiliar with the rules of chess, this implies that each row and column of the board contains
exactly one queen, and each diagonal contains no more than one.)
Write a program that will read in the number and details of the chessboards and determine the
highest scores possible for each board under these conditions. (You know that the Sultan is both a
good chess player and a good mathematician and you suspect that her score is the best attainable.)
Input
Input will consist of k (the number of boards), on a line by itself, followed by k sets of 64 numbers,
each set consisting of eight lines of eight numbers. Each number will be a positive integer less than
100. There will never be more than 20 boards.
Output
Output will consist of k numbers consisting of your k scores, each score on a line by itself and right
justified in a field 5 characters wide.
Sample Input
1
1 2 3 4 5 6 7 8
9 10 11 12 13 14 15 16
17 18 19 20 21 22 23 24
25 26 27 28 29 30 31 32
33 34 35 36 37 38 39 40
41 42 43 44 45 46 47 48
48 50 51 52 53 54 55 56
57 58 59 60 61 62 63 64
Sample Output
260
题意:你找八个点,每个点的竖排,横排,两条对角线不能有其他点 ,在所有可能的八个点中选取值的和最大的一组
解 :显然,每一数列都会有且仅有1个点,那我们只要在前7列有点的情况下找到第8列上 前7列点都不冲突的点 即找到了一组答案 ,从第1列出发 搜索for(1,8) 行的点是否有1个点 行 ,主对角,副对角都未被标记,那么继续往下搜索
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<math.h>
#include<queue>
#include<map>
#include<vector>
#include<set>
using namespace std;
#define inf 0x3f3f3f3f
#define ll long long
int n;
int a[50][50];
int v[50][50];
int ans;
void dfs(int cur,int num)
{
if(cur==8)//如果找到了8个点,那么找到了一组解
{ans=max(ans,num); //看最大值能否更新
return;}
for(int i=0;i<8;i++)
{
if(!v[0][i]&&!v[1][cur+i]&&!v[2][cur-i+8]) //v[0] 代表行 ,v[1]代表副对角线 如(1,2)(2,1) v[2]代表主对角线 如(1,2) (2,3)
{
v[0][i]=1;v[1][cur+i]=1;v[2][cur-i+8]=1;//选择那个点,标记
dfs(cur+1,num+a[cur][i]);//往下搜索
v[0][i]=0;v[1][cur+i]=0;v[2][cur-i+8]=0;//不选择那个点,取消标记
}
}
}
int main()
{
scanf("%d",&n);
while(n--)
{
ans=0;
memset(a,0,sizeof(a));
memset(v,0,sizeof(v));
for(int i=0;i<8;i++)
for(int j=0;j<8;j++)
scanf("%d",&a[i][j]);
dfs(0,0);
printf("%5d\n",ans);//格式输出
}
}