当前位置: 首页 > 工具软件 > paper-switch > 使用案例 >

hdu 1148 Rock-Paper-Scissors Tournament

卢聪
2023-12-01

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1148

题目描述:

Rock-Paper-Scissors Tournament

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1462    Accepted Submission(s): 465


Problem Description
Rock-Paper-Scissors is game for two players, A and B, who each choose, independently of the other, one of rock, paper, or scissors. A player chosing paper wins over a player chosing rock; a player chosing scissors wins over a player chosing paper; a player chosing rock wins over a player chosing scissors. A player chosing the same thing as the other player neither wins nor loses. 
A tournament has been organized in which each of n players plays k rock-scissors-paper games with each of the other players - k games in total. Your job is to compute the win average for each player, defined as w / (w + l) where w is the number of games won, and l is the number of games lost, by the player. 
 

Input
Input consists of several test cases. The first line of input for each case contains 1 ≤ n ≤ 100 1 ≤ k ≤ 100 as defined above. For each game, a line follows containing p1, m1, p2, m2. 1 ≤ p1 ≤ n and 1 ≤ p2 ≤ n are distinct integers identifying two players; m1 and m2 are their respective moves ("rock", "scissors", or "paper"). A line containing 0 follows the last test case. 
 

Output
Output one line each for player 1, player 2, and so on, through player n, giving the player's win average rounded to three decimal places. If the win average is undefined, output "-". Output an empty line between cases. 
 

Sample Input
2 4 1 rock 2 paper 1 scissors 2 paper 1 rock 2 rock 2 rock 1 scissors 2 1 1 rock 2 paper 0
 

Sample Output
0.333 0.667 0.000 1.000

题意:

猜拳算平均概率,平均概率=W / ( W + L )

题解:

算出每个人的W和L,注意空行是每个样例之间有,且最后一个样例不能有空行不然会有PE; "-"的情况是 W==L==0

代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
int n=0,k=0,cases=0;;//n people (begin with 1)  k  games
typedef struct pe
{
    int w;
    int l;
    pe()
    {
        w=0;
        l=0;
    }
}pe,* pelink;
pe peos[100+5];//begin with 1
int duel(char c1,char c2)
{
    int val=c1-c2;
    switch((int)fabs(val))
    {
        case 0:
            return(0);
        case 3:
            return(val);
        default:
            return(-val);
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n>0)
    {
        cases++;
        memset(peos,0,sizeof(peos));
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
        {
            char cs1[10],cs2[10];
            int num1,num2;
            scanf("%d%s%d%s",&num1,cs1,&num2,cs2);
            int flag=duel(cs1[0],cs2[0]);
            if(flag>0)
            {
                peos[num1].w++;
                peos[num2].l++;
            }
            else if(flag<0)
            {
                peos[num1].l++;
                peos[num2].w++;
            }
        }
        if(cases>1)//PE: the empty line is between cases
            printf("\n");
        for(int i=1;i<=n;i++)
        {
            if(peos[i].w+peos[i].l==0)
            {
                printf("-\n");
            }
            else
            {
                printf("%.3lf\n",(double)peos[i].w/(peos[i].w+peos[i].l));
            }
        }
    }
    return(0);
}





 类似资料:

相关阅读

相关文章

相关问答