当前位置: 首页 > 工具软件 > Seaside > 使用案例 >

hdu-3665 Seaside

卢枫涟
2023-12-01

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1376    Accepted Submission(s): 991


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

Sample Output
2
题意没弄懂,一直不对
大意 :一共有n组测试数据,接着每行有两个数据,mi与ni,如果ni为1则说明第i个城镇与海边相邻,接着有mi组数据,每行有两个s和L,代表的是第i个城镇相距L,求出从家(0处)到海边最近的距离
# include<cstdio>
# include<cstring>
# include<algorithm>
# define MAXA 100 + 10
# define INF 0x3f3f3f3f
using namespace std;
int n, m;
int a, b, s, l;
int dis[MAXA];
int mark[MAXA];
int map[MAXA][MAXA];

void f()
{
	for(int k = 0; k < n; k++)
		for(int i = 0; i < n; i++)
			for(int j = 0; j < n; j++)
				if(map[i][j] > map[i][k] + map[k][j])
					map[i][j] = map[i][k] + map[k][j];			
}

int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		for(int i = 0; i < n; i++)
			for(int j = 0; j < n; j++)		
				if(i == j)
				 	map[i][j] = 0;
				else
				 	map[i][j] = INF;		

		for(int i = 0; i < n; i++)
		{
			scanf("%d%d",&a,&mark[i]);
			for(int j = 0 ; j < a; j++)
			{
				scanf("%d%d",&s,&l);			
					map[i][s] = l;					
			}
		}
		f();
		int k = INF;
		for(int i = 0; i < n; i++)
		{
			if(mark[i])
			if(k > map[0][i])
			  k = map[0][i];
		
		}
		printf("%d\n",k);	  
	}
	
	return 0;
}

 类似资料:

相关阅读

相关文章

相关问答