当前位置: 首页 > 工具软件 > Argus > 使用案例 >

Argus

于嘉誉
2023-12-01

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes."
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:
Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#".

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005
 
  
//才开始没有想到这里  然后借用了其他人的博客  然后很容易就明白了; 


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<queue>
using namespace std;

struct Test{
	int qnum,period,time;
	//下面的运算符的重载是很关键的一步 
	bool operator < (const Test &a)const//这里的const是不可以缺少的 
	{
		return time>a.time||(time==a.time&&qnum>a.qnum);//考虑二者周期时间相等的时候的情况  然后对qnum 进行比较输出 
	}
};    


int main()
{
	priority_queue<Test> pq;//优先级队列; 
	char s[20];
	Test  item;
	while(scanf("%s",s)&&s[0]!='#'){
		scanf("%d%d",&item.qnum,&item.period);
		item.time = item.period;     //借用其他的变量进行周期定位 
		pq.push(item);//将item入队 
	}
	int k;
	scanf("%d",&k);
	while(k--){
		Test  it=pq.top();    
		pq.pop();
		printf("%d\n",it.qnum);//出队列; 
		it.time+=it.period;//运用这个周期循环的方法  进队列; 
		pq.push(it);//把it入队 
	} 
	return 0;
}
 
 
 类似资料:

相关阅读

相关文章

相关问答