当前位置: 首页 > 工具软件 > goda-time > 使用案例 >

杭电2672 God is a girl

陶沛
2023-12-01

god is a girl

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1337    Accepted Submission(s): 618


Problem Description
One day,when I was dreaming,god went into my dream,she was pretty cute,just like /^_^\...
I really wanted to talked to her,but my English was so poor and she was not a national god but a foreign one...After thirty minutes,she flew away...but story was not finished here,she had left a letter for me!!!What puzzled me so much is the letter was encoded.I had thought for many days,but still can't get it. Now I turn to you for help,with some limited prompts,can you help me to decode the whole letter?

Prompts:
GDJIJ,EL SSJT UT YWOSQNIVZMI. -> HELLO,MY NAME IS LINDAINVERS.
CN WLP JRVMFGQ BVR,IJCFI? -> DO YOU REQUIRE AID,HUMAN?
NMAB VYNNF, FI'E VC HP IXJ ZLQZI. -> ONCE AGAIN, IT'S UP TO THE ELVES.
...
 

Input
There is multy cases,please process to EOF.
Each case is one line of string with uppercase letters and white spaces and other symbols.
 

Output
One line of the decoded string.
 

Sample Input
SGC CGGJX GC BMHVQ BGU BCIHNYNBX GNPLV!
 

Sample Output
THE FLOWS OF MAGIC ARE WHIMSICAL TODAY!
 

Author
Teddy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2673  2668  2669  2671  2670 
 
#include<stdio.h>
#include<string.h>
int main()
{
	char str1[100000],str2[100000];
	int a[100000],i,t,j;
	memset(str1,0,sizeof(str1));
	while(gets(str1))
	{
     	memset(a,0,sizeof(a));         清零应放在while内
	memset(str2,0,sizeof(str2));
	t=strlen(str1);
	a[0]=1;
	a[1]=1;
	for(i=2;i<t;i++)
	  {
	  a[i]=a[i-1]+a[i-2];
    	while(a[i]>26)
	  a[i]-=26;
      }
     for(i=0,j=0;i<t;i++)
	 {
	 	if(str1[i]>='A'&&str1[i]<='Z')
	 	{
	 	str2[i]=str1[i]+a[j++];
	    if(str2[i]>'Z')
	 	str2[i]-=26;
	    }
	    else
	    str2[i]=str1[i];
		 }	
		 puts(str2);
      }
      return 0;
  }
<pre name="code" class="html">#include<stdio.h>
#include<string.h>
int main()
{
	char str1[100000] ;
	int a[100000],i,t,j;
	while(gets(str1))
	{
	t=strlen(str1);
	a[0]=1;
	a[1]=1;
	for(i=2;i<t;i++)
	  {
	  a[i]=a[i-1]+a[i-2];
    	while(a[i]>26)
	  a[i]-=26;
      }
     for(i=0,j=0;i<t;i++)
	 {
	 	if(str1[i]>='A'&&str1[i]<='Z')
	 	{
	 	str1[i]+=a[j++];
	    if(str1[i]>'Z')
	 	str1[i]-=26;
	    }
		 }	
		 puts(str1);
      }
      return 0;
  }

 






 
 类似资料: