当前位置: 首页 > 工具软件 > goda-time > 使用案例 >

God Save the i-th Queen

微生烨然
2023-12-01
       

I. God Save the i-th Queen

Time Limit: 5000ms
Memory Limit: 65536KB
64-bit integer IO format:  %lld      Java class name:  Main
Did you know that during the ACM-ICPC World Finals a big chessboard is installed every year and is available for the participants to play against each other? In this problem, we will test your basic chess-playing abilities to verify that you would not make a fool of yourself if you advance to the World Finals.
During the yesterday’s Practice Session, you tried to solve the problem of N independent rooks. This time, let’s concentrate on queens. As you probably know, the queens may move not only
horizontally and vertically, but also diagonally.
You are given a chessboard with i−1 queens already placed and your task is to find all squares that may be used to place the i-th queen such that it cannot be captured by any of the others.

Input

The input consists of several tasks. Each task begins with a line containing three integer numbers separated by a space:  XNXand  give the chessboard size, 1  ≤ X, Y 20 000.  i−1 is the number of queens already placed, 0  ≤ ≤ X·Y .
After the first line, there are  lines, each containing two numbers  xk, yk separated by a space. They give the position of the  k-th queen, 1  ≤ xk ≤ X, 1  ≤ yk ≤ . You may assume that those positions are distinct, i.e., no two queens share the same square.
The last task is followed by a line containing three zeros.

Output

For each task, output one line containing a single integer number: the number of squares which are not occupied and do not lie on the same row, column, or diagonal as any of the existing queens.

Sample Input

8 8 2
4 5
5 5
0 0 0

Sample Output

20
代码:
#include <iostream>
#include <cstdio>
#include <queue>
#include <math.h>
#include <cstdlib>
#include <cstring>
#include <set>
using namespace std;
int X, Y, N;
bool A[20002], B[20002];
bool Z[40004], F[40004];


int main()
{
    while (~scanf("%d%d%d", &X, &Y, &N))
    {
        if (X == 0 && Y == 0 && N == 0)
            break;
        memset(A, false, sizeof(A));
        memset(B, false, sizeof(B));
        memset(Z, false, sizeof(Z));
        memset(F, false, sizeof(F));
        for (int i = 0; i < N; i++)
        {
            int xk, yk;
            scanf("%d%d", &xk, &yk);
            A[xk] = true;
            B[yk] = true;
            Z[xk - yk + Y] = true;
            F[xk + yk] = true;
        }

        long long ans = 0;
        for (int i = 1; i <= X; i++)
        {
            for (int j = 1; j <= Y; j++)
            {
                if (!A[i] && !B[j] && !Z[i - j + Y] && !F[i + j])
                {
                    ans++;
                }
            }
        }
        printf("%lld\n", ans);
    }
    return 0;
}
 类似资料:

相关阅读

相关文章

相关问答