当前位置: 首页 > 工具软件 > Yogurt > 使用案例 >

Yogurt factory -POJ-2393

华凯捷
2023-12-01

Yogurt factory

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week.
Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt.
Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week.

Input

* Line 1: Two space-separated integers, N and S.

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

Output

* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

Sample Input

4 5
88 200
89 400
97 300
91 500

Sample Output

126900

Hint

OUTPUT DETAILS:
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

题意:给出每周牛奶生产的单价和需求量,牛奶可以生产过量并保存下来,但是需要额外交保存费,求最小需要多少钱。

解题思路:若使用之前留下来的牛奶,那么第i周和第j周牛奶单价的差价就是(j-i)*s,可以从前往后递推,保存当前周牛奶的最小价,即a[i]=min(a[i],a[i-1]+s);根据递推式可以省去和更前面的比较,只需要与上一周比较。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 1e4 + 5;
int n, s, c[maxn], y[maxn];
int main() 
{
    scanf("%d%d", &n, &s);
    for (int i = 0; i < n; i++) scanf("%d%d", c + i, y + i);
    for (int i = 1; i < n; i++) c[i] = min(c[i], c[i - 1] + s);
    long long ans = 0;
    for (int i = 0; i < n; i++) ans += c[i] * y[i];
    printf("%lld\n", ans);
    return 0;
}

 

 类似资料:

相关阅读

相关文章

相关问答