题目:
Yogurt factory
Description
The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky's factory, being well-designed, can produce arbitrarily many units of yogurt each week.
Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt's warehouse is enormous, so it can hold arbitrarily many units of yogurt. Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky's demand for that week. Input
* Line 1: Two space-separated integers, N and S.
* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i. Output
* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.
Sample Input 4 5 88 200 89 400 97 300 91 500 Sample Output 126900 Hint
OUTPUT DETAILS:
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units. Source |
[Submit] [Go Back] [Status] [Discuss]
思路:有一个奶牛场,他要向客户供奶,一共要n周,但是生产牛奶的单位价格每一周都不一样,他有一个仓库,可以保存牛奶而且永不过期,每保存一周有固定的保存费用s,现在给出n周的每周生产单位牛奶的价格和每周要和客户供奶的量,求最小花费是多少
我们可以用贪心的思想,维护一个c=min(c,minc+s)来看一下这一周是保存牛奶比较好还是直接生产比较好,具体看代码
代码:
#include<cstdio>
#include<cstring>
#include<string>
#include<set>
#include<iostream>
#include <cmath>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define mod 10000007
#define debug() puts("what the fuck!!!")
#define N (1010)
#define ll long long
using namespace std;
int main()
{
ll n,s,minc = inf;
scanf("%lld%lld",&n, &s);
ll sum = 0;
while(n --)
{
ll c, y;
scanf("%lld%lld",&c, &y);
c=min(c,minc+s);
minc = c;
sum +=c*y;
}
printf("%lld\n", sum);
return 0;
}