DreamGrid went to the bookshop yesterday. There are books in the bookshop in total. Because DreamGrid is very rich, he bought the books according to the strategy below:
BaoBao is curious about how rich DreamGrid is. You are asked to tell him the maximum possible amount of money DreamGrid took before buying the books, which is a non-negative integer. All he knows are the prices of the books and the number of books DreamGrid bought in total, indicated by .
Input
There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:
The first line contains two integers and (, ), indicating the number of books in the bookshop and the number of books DreamGrid bought in total.
The second line contains non-negative integers (), where indicates the price of the -th book checked by DreamGrid.
It's guaranteed that the sum of in all test cases will not exceed .
Output
For each test case output one line.
If it's impossible to buy books for any initial number of money, output "Impossible" (without quotes).
If DreamGrid may take an infinite amount of money, output "Richman" (without quotes).
In other cases, output a non-negative integer, indicating the maximum number of money he may take.
Sample Input
4 4 2 1 2 4 8 4 0 100 99 98 97 2 2 10000 10000 5 3 0 0 0 0 1
Sample Output
6 96 Richman Impossible
这个题目有很大的迷惑性(尤其是有第三个条件),一开始读完还以为是贪心,结果根本不是。。。。就是买书的话都是买的连续的且是前几个。。。问问最少多少钱(注意零的情况),钱数等于买的书的价格加上第一个不为零的书价减一。。。。
代码:
#include <iostream>
#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
using namespace std;
int main()
{
int T;
int n,m;
int s;
int a[100005];
scanf("%d",&T);
while(T--)
{
s = 0;
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
if(a[i]==0)
s++;
}
if(s>m)
printf("Impossible\n");
else if(n==m)
printf("Richman\n");
else
{
long long ans = 0;
int mn = INF;
int mm = 0;
for(int i=0;i<n;i++)
{
if(mm+s<m)
{
if(a[i]==0)
continue;
ans+=a[i];
mm++;
}
else
{
if(a[i]==0)
continue;
mn = min(mn,a[i]);
}
}
ans+=(long long)(mn-1);
printf("%lld\n",ans);
}
}
return 0;
}