当前位置: 首页 > 工具软件 > Gumbo > 使用案例 >

poj 2584 T-Shirt Gumbo 二分匹配

宫亦
2023-12-01
T-Shirt Gumbo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2935 Accepted: 1376

Description

Boudreaux and Thibodeaux are student volunteers for this year's ACM South Central Region's programming contest. One of their duties is to distribute the contest T-shirts to arriving teams. The T-shirts had to be ordered in advance using an educated guess as to how many shirts of each size should be needed. Now it falls to Boudreaux and Thibodeaux to determine if they can hand out T-shirts to all the contestants in a way that makes everyone happy.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 

A single data set has 4 components: 
  1. Start line - A single line: 
    START X 

    where (1 <= X <= 20) is the number of contestants demanding shirts. 
  2. Tolerance line - A single line containing X space-separated pairs of letters indicating the size tolerances of each contestant. Valid size letters are S - small, M - medium, L - large, X - extra large, T - extra extra large. Each letter pair will indicate the range of sizes that will satisfy a particular contestant. The pair will begin with the smallest size the contestant will accept and end with the largest. For example: 
    MX 

    would indicate a contestant that would accept a medium, large, or extra large T-shirt. If a contestant is very picky, both letters in the pair may be the same. 
  3. Inventory line - A single line: 
    S M L X T 

    indicating the number of each size shirt in Boudreaux and Thibodeaux's inventory. These values will be between 0 and 20 inclusive. 
  4. End line - A single line: 
    END 

After the last data set, there will be a single line: 
ENDOFINPUT 

Output

For each data set, there will be exactly one line of output. This line will reflect the attitude of the contestants after the T-shirts are distributed. If all the contestants were satisfied, output: 

T-shirts rock! 

Otherwise, output: 
I'd rather not wear a shirt anyway... 

Sample Input

START 1
ST
0 0 1 0 0
END
START 2
SS TT
0 0 1 0 0
END
START 4
SM ML LX XT
0 1 1 1 0
END
ENDOFINPUT

Sample Output

T-shirts rock!
I'd rather not wear a shirt anyway...
I'd rather not wear a shirt anyway...
//二分匹配,把队员看成第一点集,衣服看成第二点集,学生接受衣服的范围和衣服都要预处理一下,之后套匈牙利模板,最大匹配若等于学生数,即能使所有人满意
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;

const int N = 510;

int match[N];
bool use[N];
bool s[N][N];
int n, k;

bool dfs(int v)
{
    for(int i = 0; i < N; i++)
    {
        if(s[v][i] == true && use[i] == false)
        {
            use[i] = true;
            if(match[i] == -1 || dfs(match[i]))
            {
                match[i] = v;
                return true;
            }
        }
    }

    return false;
}

int hungary()
{
    int res = 0;
    memset(match, -1, sizeof match);
    for(int i = 0; i < n; i++)
    {
        memset(use, 0, sizeof use);
        if(dfs(i)) res++;
    }

    return res;
}

int ju(char a)
{
    if(a == 'S') return 1;
    else if(a == 'M') return 2;
    else if(a == 'L') return 3;
    else if(a == 'X') return 4;
    else return 5;
}

int main()
{
    char str[20];
    char a, b;
    int aa[N], bb[N], tmp[10] = {};


    while(scanf(" %s", str), strcmp(str, "ENDOFINPUT") != 0)
    {
        scanf("%d", &n);

        memset(s, 0, sizeof s);
        for(int i = 0; i < n; i++)
        {
            scanf(" %c%c", &a, &b);
            aa[i] = ju(a); //预处理队员可接受的衣服范围,转换为数字
            bb[i] = ju(b);
        }

        for(int i = 1; i <= 5; i++)
        {
            scanf("%d", tmp + i);
            tmp[i] += tmp[i-1]; //预处理衣服,把每一件衣服独立成一个点
        }
        scanf(" %s", str);
        for(int i = 0; i < n; i++)
        {
            for(int j = aa[i]; j <= bb[i]; j++)
            {
                for(int k = tmp[j-1] + 1; k <= tmp[j]; k++)
                    s[i][k] = true;
            }
        }

        if(hungary() == n) printf("T-shirts rock!\n");
        else printf("I'd rather not wear a shirt anyway...\n");
    }

    return 0;
}


 类似资料: